[OS X TeX] Fatal format file error - pdflatex.fmt doesn't match pdfetex.pool

Gerben Wierda Gerben.Wierda at rna.nl
Tue Nov 1 22:06:22 CET 2005

On Nov 1, 2005, at 21:44, Hemant Bhargava wrote:

> Hi -
> I just installed tetex (the "TeX" package from Gerben's site) - and I 
> get the following error on running it :
> This is pdfeTeX, Version 3.141592-1.20a-2.2 (Web2C 7.5.3)
> ---! /Users/hemantb/Library/texmf/web2c/pdflatex.fmt doesn't match 
> pdfetex.pool
> (Fatal format file error; I'm stymied)
> I reinstalled TeX a couple of times. Then I tried rebuilding the 
> formats using fmutil -- all . I also had to fix directory permissions 
> for ls-R files. But even after all that I still get the same error.
> I can't quite figure out what's going on. The only difference with 
> other occasions where I installed tetex is : this time when I set up 
> the new machine, I had it "get information" about my accounts from the 
> previous machine through a firewire connection. Perhaps something is 
> set differently?
> At any rate, can someone suggest how to fix it? I hate to have to 
> reinstall everything from scratch.

/Users/hemantb/Library/texmf/web2c is a possible left-over from the 
experimental i-Package of last month which supported per-user 
configuration. Unless you are a TeXpert ad you have stuff in 
/Users/hemantb/Library/texmf/web2c, you can safely remove that 
subdirectory, or at least all the .fmt files in there.


------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list