[OS X TeX] Tiger Problem Solved! (I Hope)

Herb Schulz herbs at wideopenwest.com
Sat May 14 17:49:29 CEST 2005


Unfortunately, my original request went to the wrong list but I'll put the
apparent solution here since this list is probably has the members of the
other list and it is a bit broader.

To reiterate...

After installing Tiger (as an Upgrade, not a Clean Install - I've never had
any problems doing that and almost everything goes great - I had to re-run
the Ghostscript and TeX i-package Configuration scripts to fix up the PATH
for CLI use) I ran into a problem with files not opening as expected. The
only way I could get TeXShop to open when double clicking a .tex document
was to make TeXShop the default application for all files of file type TEXT:
any attempt to change things in the Get Info and set it for all files of
that type was immediately rejected and reset to the default application

Given the helpfulness of this list (and the other one too!!!) I cried for

Bruno Voisin finally got me moving in the right direction with the following
information (I Hope he doesn't mind me posting most of his helpful e-mail):

It may also be caused by a corrupted LaunchServices database or
cache. I think Adam Maxwell on the OS X TeX list told once you need
to trash the following files:


then log off and on, or restart.

Looking at the same locations in Tiger, the above files seem to have
become, respectively:


The first file corresponds to the System Administrator (root user).
The second file corresponds to a normal user account (501 is my user
number), and there are other similar files inside /Library/Caches/
for other users of your Mac. For example, I have also a file


corresponding to my GF's account (as seen from the corresponding user/
group flags, using "ls -l" in Terminal).

It might be nice, once a solution is found, to post it back to the
MacTeX list, in case people there saw the original question and were
planning to investigate.

Given the last paragraph, here I am!

After moving the three files (I have only one other user and she [my wife]
didn't have any special bindings outside of the defaults) noted to my
Desktop (You need an administrator password to move the first two) I
restarted the system. I got a message that I would have to power down and
restart (I assume the missing Cache file confused the system) and after
doing that everything came back.

Some extra notes. I used RCDefaultApp, a very nice Preference Pane,
<http://www.rubicode.com/Software/RCDefaultApp/>, to change the default
opening program for file extensions .tex, .cls, .clo, .sty and .dtx to
TeXShop (some defaulted to AlphaX or iTeXMac) which is what I mostly use.
While not fully updated for Tiger it works for changing default applications
for extensions.

Finally, I'm beginning to think the problem started because I set up Stuffit
Expander to unstuff all possible compressed file type it knows about (I've
got Stuffit Deluxe) from within its preferences. This time around I used
RCDefaultApp to use Expander for .sit, .sitx files.

Hopefully I can now go back to playing with Tiger.

Good Luck,

Herb Schulz
(herbs at wideopenwest.com)

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list