[OS X TeX] Alpha taking over some file extensions

Bruno Voisin bvoisin at mac.com
Tue May 3 23:46:14 CEST 2005

Le 3 mai 05 à 19:44, Jon Guyer a écrit :

> An application bundle is not strictly required to have a .app  
> extension, but unless several other criteria are met, it is /not/  
> an application without it, at which point it's fair game for any  
> app that claims whatever extension it does have. Nonetheless, I see  
> that Fetch 4.0.3 is not an application bundle; it is an old style  
> resource-based CFM application with type/creator of APPL/FTCh. The  
> documentation for the Finder and LS certainly seems to indicate  
> that this is unambiguous and should launch as an application. It  
> has the proper plst resource, so I don't see any problems with it.

Thanks for the clarification. The problem seems odd, and not really  
reproducible: first, after installing Tiger, when I installed Fetch  
everything was OK. The only odd thing was that Fetch did not have the  
icon I had got familiar with on OS X, namely a liquid-looking dog  
seen halfway from the side (the icon at Fetch's home page), but an  
older icon representing a dog's face holding a floppy in its mouth.  
Then suddenly, after a few hours and with no apparent reason (or  
possibly installing AlphaX afterwards, I'm not sure), Fetch had  
become an Alpha document, as verified by double-clicking on it, and  
everytime I tried to unstuff the original archive Fetch_4.0.3.sit  
gave this very same result at once. After removing the " 4.0.3" from  
the name or adding .app at the end of it (using the view info window,  
and answering Yes to the question that arise when closing this  
window), then it's an application again and Fetch has got its  
familiar icon back.

> Alpha does define certain wildcard extensions and creator codes,  
> but according to the LaunchServices documentation: "To allow an  
> application to accept files of unrestricted file type or extension  
> during drag-and-drop operations, you can use the special wild-card  
> values '****' or '*' for CFBundleOSTypes or CFBundleTypeExtensions,  
> respectively. (These are honored only in drag-and-drop operations  
> and not when the user opens a document by double-clicking.)", so if  
> the Finder is opening these in Alpha when you double-click on them,  
> then that's a bug in the Finder or in LS (I'm shocked, *shocked* I  
> say. A bug in a .0 OS release from Apple?!).
> This is all just speculation. I'm not running Tiger and will not be  
> so delusional as to install it until at least 10.4.1.

A similar though slightly different behaviour: if you plan to install  
DivX (don't: it doesn't work on Tiger, and yields duplicated help  
menus in iWork applications) and download the archive DivX521.sit  
from <http://www.divx.com/divx/download/>, then upon unstuffing the  
extracted folder "DivX 5.2.1" will be seen by Tiger as such  (a  
folder) whereas it is actually (and was seen by Panther as) an  
application bundle. Again, removing " 5.2.1" from the name or adding  
the .app extension solves the issue.

Actually the Daring Fireball "Tiger Details" blog entry <http:// 
daringfireball.net/misc/2005/04/tiger_details> mentions something  
possibly related (go to "‘.APP’ FILE EXTENSIONS" at the bottom of the  
page): Tiger treats .app extension differently from what it did  
before. Beforehand, if you asked the Finder to display all  
extensions, it was still hiding .app ones; with Tiger, it doesn't.

BTW, this blog entry is really interesting and useful for revealing  
hidden gems in Tiger. For example it mentions this, which should  
affect TeXShop for example: the Cocoa text editing "framework"  
NSTextView allows discontinuous text selection with Command-drag, and  
column selection with Option-drag.

> Possible issues:
>    1) Alpha is indeed claiming things more aggressively than it  
> should. We will investigate and correct this, if true.
>    2) Your Launch Services database is corrupt. Depending on who  
> you talk to, this is either much more common or much less common  
> than old-style Desktop database corruption.

The fact that the Fetch problems above did not arise at once might  
indicate this is so. I had got from somewhere (probably a post to  
this list) the instructions that, for forcing this database to be  
rebuilt, the following files needed to be erased:


Is this correct?

>    3) Tiger is buggy. The probability that this is /not/ true lies  
> in the complex plane.

After almost two days "polishing" my Tiger install, getting familiar  
with it and solving the problems that arose because of it, I can but  
agree this is truly understatement!

Bruno Voisin--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list