[OS X TeX] Problem for EPS -> PDF conversion with TeXShop 1.35

Bruno Voisin bvoisin at mac.com
Wed Sep 1 23:12:59 CEST 2004

On 1 sept. 04, at 16:19, Gary L. Gray wrote:

> On Sep 1, 2004, at 4:54 AM, Bruno Voisin wrote:
>> Has anybody else been faced with a problem re. the automatic 
>> conversion from EPS to PDF when a file is dragged onto the TeXShop 
>> icon, for TeXShop 1.35 and EPS files whose complete path include 
>> spaces?
> I just tried it here with 1.35b and it worked as expected -- no 
> problems. This was with an EPS file right out of Mathematica.

Hi all,

This is just to report further test, so that people -- Dick? -- do not 
consider this question solved once and for good.

I asked Gary to put the EPS file to convert inside a directory whose 
name contains a space, and then try again. He but confirmed the bug 
report (Gary, I hope you don't mind being cited without getting asked 
first, in this particular case):

> On Sep 1, 2004, at 10:58 AM, Bruno Voisin wrote:
>> Did you try after putting the EPS file inside a directory whose name 
>> contains a space, for example "~/Desktop/Test 1/"? It's in this case 
>> that I experienced a problem.
> I just tried. Here is the setup ...
> I created a folder with a space in the name:
> ~/Desktop/untitled folder/
> I out an EPS file entitled "ay-vs-y-plot.eps" in it. I then dropped 
> the EPS on TeXShop and I got bad PDF on my desktop entitled 
> "untitled".
> So yes, it doesn't work here either. Here is what I got in the Console:
> Error: /undefinedfilename in (folder/ay-vs-y-plot.pdf)
> Operand stack:
> Execution stack:
>    %interp_exit   .runexec2   --nostringval--   --nostringval--   
> --nostringval--   2   %stopped_push   --nostringval--   
> --nostringval--   --nostringval--   false   1   %stopped_push
> Dictionary stack:
>    --dict:1110/1686(ro)(G)--   --dict:0/20(G)--   --dict:69/200(L)--
> Current allocation mode is local
> Last OS error: 2
> AFPL Ghostscript 8.13: Unrecoverable error, exit code 1
> Broken pipe

So this is analogous to what I got: a file created, with name the part 
of the path before the first space, and an error in console.log 
mentioning the part of the path between the first and second (if any) 

I looked at epstopdfwrap inside TeXShop.app: it generates the file 
name, fed to epstopf, from the variable ${filename}. However, I 
couldn't identify where ${filename} comes from (i.e., is it generated 
by TeXShop, or is it a standard shell or perl variable), as this is 
getting clearly beyond my programming ability. Besides, I cannot guess 
what could have changed, between v1.34 and v1.35, which could affect 
this. And I couldn't identify either where, in the source of TeXShop, 
the action, associated with dragging an EPS file onto TeXShop, is 

Bruno Voisin

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list