[OS X TeX] New TeX i-Package released

Gerben Wierda Gerben.Wierda at rna.nl
Tue Oct 26 20:30:25 CEST 2004

On 26 Oct 2004, at 18:37, Piet van Oostrum wrote:

> I had a couple of problems with the new texlive 2004 setup:
> First after installing it I couldn't run latex or pdflatex, they gave 
> a I'm
> stymied error. It appeared that the latex.fmt and pdflatex.fmt were not
> built. Although the installation process ended with:
> Running the configuration script finished without critical errors.
> the creation of latex.fmt and pdflatex.fmt had failed. The problem is 
> that
> I have selected Spanish as one of the languages and the Spanish 
> hyphenation
> file used to be sphyphen.tex, but now is eshyphen.tex. But is hasn't 
> been
> changed in language.dat.

It has been changed in language.dat but since I do not touch 
texmf.local an old language.dat is found first. I provide a workaround 

> After changing and reconfiguring it worked.
> Secondly The latin modern fonts didn't work (this was reported here
> earlier). I run the updmap commands separately that gerben advised but 
> it
> didn't solve the problem. It appears that running updmap generates
> psfonts.map pdftex*.map dvipdfm*.map and ps2pk.map in
> /usr/local/teTeX/share/texmf.local/fonts/map/.../updmap/ but I had 
> otehr
> ones in /usr/local/teTeX/share/texmf.local/fonts/map/dvips/config/ and
> these had timestamps of my first attempt to install.

I need to loke at this. It would be nice to know what old stuff can get 
in the way. I could offer a conditional removal.

> So I removed these and
> now they appear to work. However I still have problems with TeXniscope
> showing DVI files with lmodern.
> I also noted that there is an outdated answers.sty.
> The last problem is very strange, and I haven't been able to diagnose 
> it
> properly. I have a file that uses beamer, but through my own class. It 
> runs
> properly with pdflatex, but not with latex. In the latter case it 
> gives a
> strange undefined control sequence. I must investigate what causes 
> tris.
> ! Undefined control sequence.
> \GenericError  ...
>                                                     #4  \errhelp 
> \@err@     ...
> l.13 \maketitle

I'll look into this.


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list