[Mac OS X TeX] [ANN] LaTeX enhanced mac-emacs (v. 1.1)

Warren Nagourney warren at dirac.phys.washington.edu
Thu Feb 28 20:02:14 CET 2002

--On Thursday, February 28, 2002 11:16 AM +0000 Enrico Franconi 
<franconi at cs.man.ac.uk> wrote:

> On February 28, karim Daho writes:
>> On 02-02-28 02.56, "Enrico Franconi" <franconi at cs.man.ac.uk> wrote:
>> > To make a full install simply type from a terminal:
>> >
>> > sudo ./mac-emacs-install <machine-name>
>> Hi there
>> Can you please tell me what to do
>> [localhost:~] karim% ls
>> Addresses           Library             Pictures            bin
>> Applications        Movies              Public              foo.tex
>> Desktop             Music               SME
>> mac-emacs-install
>> Documents           Netscape            Sites               texmf.cnf
>> [localhost:~] karim% sudo ./mac-emacs-install MacX
>> sudo: ./mac-emacs-install: command not found
>> [localhost:~] karim%
> OK. First, you should unzip/untar the file you downloaded. It seems
> you did it.  Then, you go into the newly created directory - with a
> cd mac-emacs-install
> it seems you did not do this step. Finally, from that directory you type
> sudo ./mac-emacs-install <machine-name>
> hope this helps
> -- e.
> Enrico Franconi                     - franconi at cs.man.ac.uk
> University of Manchester            - http://www.cs.man.ac.uk/~franconi/
> Department of Computer Science      - Phone: +44 (161) 275 6170
> Manchester M13 9PL, UK              - Fax:   +44 (161) 275 6204

I had a problem which was due to Stuffit Expander's inability to properly 
unpack the archive - it missed a number of the elements, including the 
all-important install-mac-emacs script. When I cd'ed into the unpacked 
archive, I found no installer script of that name, so I assumed 
(uncorrectly) that the parent directory - which has this exact name- was 
the script. As a result, I had exactly the same error as Karim.

My solution was to turn off automatic unstuffing in IE (which I used to 
download the archive) and use tar and gzip to generate the proper 
directories. Then, I cd'ed into the folder and used the install-mac-emacs 
script just as suggested in the readme. Everything then worked (though 
there are a number of bugs in the resulting application, one of which is 
having mouse-overs permanently select info headings in the help files).

Hope this helps.

Warren Nagourney

Warren Nagourney   <warren at dirac.phys.washington.edu>  Voice: 206-543-9585
University of Washington                                      206-543-0143
Physics Dept., Box 351560, Seattle, WA 98195             Fax: 206-685-0635

To UNSUBSCRIBE, send email to <info at email.esm.psu.edu> with
"unsubscribe macosx-tex" (no quotes) in the body.
For additional HELP, send email to <info at email.esm.psu.edu> with
"help" (no quotes) in the body.
This list is not moderated, and I am not responsible for
messages posted by third parties.

More information about the macostex-archives mailing list