[Mac OS X TeX] paths & the terminal - command line no longer works

Gary L. Gray gray at engr.psu.edu
Sun Sep 30 04:49:53 CEST 2001

<x-flowed>On 09/29/2001 at 10:07 PM -0400, Arun Mangalam wrote:

>It worked before because you used Wierda's nice package to install 
>tetex. The installer sets paths in one of the files [I'm not sure 
>which] in the directory "/usr/share/init/tcsh". The paths that it 
>sets is just the directory of tex binaries: 
>"/usr/local/teTeX/bin/powerpc-apple-darwin1.3.7". You can set that 
>path in your home directory, OR, like the installer, set it again in 
>[maybe?] "/usr/share/init/tcsh/environment" and hope that Apple 
>doesn't it overwrite the file again :).

You are quite correct! I did reinstall using Wierda's teTeX and it 
still did not work. I forgot that I needed to log out and then log 
back in. Now it works like a charm (again). The file that appears to 
be the relevant one is:


which has the lines:

# teTeX modifications have been added Sat Sep 29 10:55:15 EDT 2001
set path = ( ${path} /usr/local/teTeX/bin/powerpc-apple-darwin1.3.7 )
setenv MANPATH "${MANPATH}:/usr/local/teTeX/man:/usr/local/man"

Thank you!

    Gary L. Gray
    Associate Professor
    Engineering Science & Mechanics
    Penn State University
    (814) 863-1778

To UNSUBSCRIBE, send email to <info at email.esm.psu.edu> with
"unsubscribe macosx-tex" (no quotes) in the body.
For additional HELP, send email to <info at email.esm.psu.edu> with
"help" (no quotes) in the body.
This list is not moderated, and I am not responsible for
messages posted by third parties.

More information about the macostex-archives mailing list