[lucida] Odd bug with Lucida Bright Math OT, icomma and TeX Live 2015

Bruno Voisin bvoisin at icloud.com
Tue Sep 8 20:03:49 CEST 2015

> On 08 Sep 2015, at 18:27, Vincent Goulet <vincent.goulet at me.com> wrote:
> The following MWE worked as expected on TeX Live 2014:
> [...]
> With TeX Live 2015, compilation just hangs at the line with a comma in a displayed equation. Stopping the compilation yields
> ^C! Interruption.
> ,->\futurelet 
>              \@let at token \sm at rtcomma 
> l.10   x = y + 2,
> ?
> The comma does not cause problems with inline equations. Using package ncccomma instead of icomma fixes the problem.

Same here on the Mac: XeLaTeX and LualaTeX both halting forever in the middle of compilation with no console output of any sort (and XeLaTeX consuming about 98% of processor ressources).

This seems to be an incompatibility between icomma on one hand, and XeLaTeX and LuaLaTeX on the other hand. Lucida isn't involved here, exactly the same happens for other Unicode math fonts (I tried with Cambria Math).

The problem seems to be known, and for LuaLaTeX a package lualatex-math (included in TL 2015) takes care of it; see §5.9 of lualatex-math.pdf. For XeLaTeX things are cured by including the relevant code in your preamble, BEFORE loading icomma.

Like that:

\setmathfont{Lucida Bright Math OT}
\AtEndOfPackageFile * { icomma } {
  \tl_replace_once:Nnn \@begindocumenthook {
\mathchardef \mathcomma \mathcode `\, }{
    \@@_set_mathchar:NN \mathcomma \,


 x = y + 2,


Works on my setup.

Hope this helps,

Bruno Voisin

More information about the lucida mailing list