[lucida] installation

ivo welch ivo_welch at brown.edu
Thu Jan 25 22:00:18 CET 2007

dear TeXperts:

I am trying to upgrade to the TeXLive distribution.  Alas, not
everything is rosy in my tex-land, even though I tried to follow
instructions religiously.  First, I purged my old tetex, and purged all
tex related environment variables.  I also killed ~/.tex* .   Then I
installed texlive 2007 on my amd64 linux gentoo system.  The
installation went well and TL seems to work.

I then tried what I thought were the lucida installation steps:

 # cd /usr/local/texlive/texmf-local/ ; unzip lucida.zip   # from ctan
    # this leaves me with a /usr/local/texlive/texmf-local/lucida/ hierarchy
 # cp l*.pfb /usr/local/texlive/texmf-local/fonts/type1/local/bh/lucida/  # from purchase
    # note the above is a hybrid path, reading the lucida install file and noting that
    # lucida.zip creates /usr/local/texlive/texmf-local/fonts/type1/local/
 # texhash
 # updmap

Next, I created my small test file

% shameless copy: I am not sure what this does, but I presume it should work
\usepackage{textcomp} % to get the right copyright, etc. % use Lucida
fonts for both text and math.
\usepackage[altbullet]{lucidabr}     % get larger bullet
\DeclareEncodingSubset{TS1}{hlh}{1}  % including \oldstylenums
{\LARGE Print me} ok \par
hello world\par
% The following causes a complete error --- maybe because it does try to
load lucida

The sample file compiles, but it works only because it seems to use
computer-modern as its font.  if I comment out the \end{document} in the
middle, then lucida seems to want to load (good), but not work (bad).  I
get the following:
Running mktextfm hlcrima
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1;
nonstopmode; input hlcrima
This is METAFONT, Version 2.71828 (Web2C 7.5.6)

kpathsea: Running mktexmf hlcrima
! I can't find file `hlcrima'.
<*> ...=ljfour; mag:=1; nonstopmode; input hlcrima

Please type another input file name
! Emergency stop.
<*> ...=ljfour; mag:=1; nonstopmode; input hlcrima

Transcript written on mfput.log.
grep: hlcrima.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode;
input hlcrima' failed to make hlcrima.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font OML/hlcm/m/it/14.4=hlcrima at 13.24796pt not loadable: Metric
(TFM) file
 not found.
<to be read again>
l.21 \maketitle

There must be some obvious magic font step I am missing.  can someone
who knows please fill me in?


/ivo welch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/lucida/attachments/20070125/3cb34b91/attachment.html 

More information about the lucida mailing list