[lucida] Installatiion problem under TeXLive

Thomas, Larry LTHOMAS at spc.edu
Mon Jun 12 20:01:20 CEST 2006

Hi, all ... Especially Karl:

I'm sorry to have let this thread go so long, but it is just now that I
really need the Lucida fonts, so I am back at it. (I appended my
original inquiry to the end of Karl's response, shown below.)

In response to Karl's suggestions, I put !!$TEXMFLOCAL, at the beginning
of the TEXMF = line in both  \texmf\web2c\texmf.cnf and
\texmf-var\web2c\texmf.cnf. (For some reason, Windows XP thinks
texmf.cnf is a "speed dial" file and makes it very hard to change it.)
But that didn't work; I got the same error messages indicating that TeX
could not find the Lucida fonts. 

Then I removed the Lucida-related .sty files from latex/psnfssx and
re-ran mktexlsr, and then the Lucida sample file with the result :

! LaTeX Error: File `lucidabr.sty' not found.

I checked, and lucidabr.sty is in c:\program files\TeXLive\texmf-local,
along with the other Lucida files.

I don't know what to try next, so any suggestions are welcomed. If all
else fails, maybe someone can help me with it at Practical TeX 2006 in


>>Karl's response to my original post:

Subject: Re: [lucida] Installatiion problem under TeXLive

Hi Larry,


It seems your system is finding an older version of the .fd files (and
maybe others, in the part you snipped), instead of the new one from TUG.

Ordinarily, I thought TL configured things so that the local tree would
be found first (I know that's true on Unix).  You might look for your
texmf.cnf (c:/Program Files/TeXLive/texmf*/web2c/texmf.cnf) and see what
the ordering is in the line: TEXMF = ... (About 100+ lines from the

Meanwhile, another way to fix it would be to move all the old
Lucida-related files in latex/psnfssx out of the tree entirely, rerun
mktexlsr, and then it should find the new ones.

Hope this helps,
>>My original post:

  I'm trying to install the Lucida fonts, but I've run into a snag.
  (Part of the log file is included at the end of this message.)

Here is what I have done:
I unzipped font files to c:\program files\TeXLive\texmf-local
I updated textcomp.sty
I ran mktexlsr from a command window with the following results:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

mktexlsr: Updating c:/Program Files/TeXLive/texmf-var/ls-R...
mktexlsr: Updating c:/Program Files/TeXLive/texmf-local/ls-R...
mktexlsr: Updating c:/Program Files/TeXLive/texmf/ls-R...
mktexlsr: Done.


I tried lucida-sample.tex and got the following (in part):

This is e-TeXk, Version 3.141592-2.1 (Web2c 7.5.2)
 %&-line parsing enabled.
 (c:/Program Files/TeXLive/texmf/web2c/cp8bit.tcx)
entering extended mode
LaTeX2e <2001/06/01>


(c:/Program Files/TeXLive/texmf/tex/latex/psnfssx/omlhlcm.fd)kpathsea:
Running m
ktextfm hlcrima
mktextfm: Could not map typeface abbreviation lc for hlcrima.
mktextfm: Need to update c:/Program
mktextfm: Running mf "\mode:=ljfour; mag:=1; nonstopmode; input hlcrima"
This is METAFONT, Version 2.71828 (Web2c 7.5.2) (c:/Program

kpathsea: Running mktexmf hlcrima
mktexmf: empty or non-existent rootfile!
! I can't find file `hlcrima'.
<*> ...=ljfour; mag:=1; nonstopmode; input hlcrima

Please type another input file name
! Emergency stop.
<*> ...=ljfour; mag:=1; nonstopmode; input hlcrima

Transcript written on mfput.log.
mktextfm: warning: can't open log file hlcrima.log.
mktextfm: `mf "\mode:=ljfour; mag:=1; nonstopmode; input hlcrima"'
kpathsea: Appending font creation commands to missfont.log.

! Font OML/hlcm/m/it/17.28=hlcrima at 15.72485pt not loadable: Metric
(TFM) fil
e not found.
<to be read again>
l.81 \maketitle



I can kind of see what the problem is, but I don't know how to fix it.

Thanks for your help


More information about the lucida mailing list