[luatex] [Dev-luatex] luatex and harfbuzz 2.5.1

Patrick Gundlach patrick at gundla.ch
Wed Jul 3 14:11:42 CEST 2019

> I have tried current experimental and did a 
> local harfbuzz = require("harfbuzz")
> maybe 
> local harfbuzz = require("luaharfbuzz")

no, although I'd expect it from luastuff.c / l. 192 to work.

I have found the symbol in the binary, so it looks OK.

$ nm bin/sdluatex | grep harf
000000010030abc0 T _luaopen_luaharfbuzz

The binary version number is 1.11.0

Any more ideas?

When I run 

build/texk/web2c/luajittex --ini
and I input
\catcode`\{=1 \catcode`\}=2 \directlua{ require("luaharfbuzz") } 

I get an error message, but when I load other libraries such as sha2, I don't get an error message

$ build/texk/web2c/luajittex --ini
warning: kpathsea: configuration file texmf.cnf not found in these directories: 
This is LuajitTeX, Version 1.11.0 (TeX Live 2020/dev)  (INITEX)

*\catcode`\{=1 \catcode`\}=2 \directlua{ require("luaharfbuzz") } 
[\directlua]:1: module 'luaharfbuzz' not found:
	no field package.preload['luaharfbuzz']
	[kpse lua searcher] file not found: 'luaharfbuzz'
	[kpse C searcher] file not found: 'luaharfbuzz'
stack traceback:
	[C]: in function 'require'
	[\directlua]:1: in main chunk.
<*> ...code`\}=2 \directlua{ require("luaharfbuzz") }
? x
No pages of output.
Transcript written on texput.log.


More information about the luatex mailing list