[luatex] signal SIGSEGV, Segmentation fault., lualatex, TexLive 2015 on Linux mint

Atsuhito Kohda atsuhito_k at tokushima-u.ac.jp
Tue Mar 15 06:39:22 CET 2016

Hi all,

On Mon, 14 Mar 2016 07:02:02 -0500, "Nasser M. Abbasi" wrote:

> I have a large latex file. When I run lualatex using this command:
> lualatex report.tex
> I get a core dump

I'm not sure if this helps you or not but FYI:

On Debian, I get a core dump (at second run) but if
one removed report.toc then lualatex worked fine.
Removing report.aux doesn't fix a core dump.

Now I find that if one put \end{document} as follows:

\int \mathrm{e}^{- 3\, \mathop{\mathrm{arctanh}}\nolimits\!\left(a\, x\right)}\, \sqrt{c - a\, c\, x} \,d x
\end{document}% this line!
\subsubsection{\quad (\# 1070)\quad $\int \frac{e^{-3 \tanh ^{-1}(a x)}}{\sqrt{c-a c x}} \, dx$}

then lualatex works fine (one sees warnings of cource).

I don't investigate the problem any further but it looks
something might exceed its limits.

Best regards,	    	       2016-3-15(Tue)

 Atsuhito Kohda
 Dep. Math., Tokushima Univ.
 atsuhito_k AT tokushima-u.ac.jp

More information about the luatex mailing list