[luatex] signal SIGSEGV, Segmentation fault., lualatex, TexLive 2015 on Linux mint

Nasser M. Abbasi nma at 12000.org
Mon Mar 14 13:52:27 CET 2016

Another fact point:

This might be related to file limits and lualatex includegraphics not
closing files?


But I have increased file limits to 100000 and still I get core dump.
I do not get "Too many open files" error. I only see a crash. But
it is possible there are related somehow as it was mentioned to me
at tex.stackexchange that the above error message was seen
trying lualatex on the latex file, but not the crash.

Is file limit still an issue with lualatex includegraphics?

ps. file is in the zip, linked to in the original message.

On 3/14/2016 7:02 AM, Nasser M. Abbasi wrote:
> I have a large latex file. When I run lualatex using this command:
> lualatex report.tex
> I get a core dump
> Core was generated by `lualatex report.tex'.
> Program terminated with signal SIGSEGV, Segmentation fault.
> #0  0x0000000000508782 in ?? ()
> This happens only with lualatex and not with pdflatex and it happens
> on this latex file (it is large latex file).
> I am on Linux mint
>> uname -r
> 3.16.0-38-generic
>> lsb_release -a
> No LSB modules are available.
> Distributor ID:	LinuxMint
> Description:	Linux Mint 17.2 Rafaela
> Release:	17.2
> Codename:	rafaela
> I am using TL 2015.
> lualatex -v
> This is LuaTeX, Version beta-0.80.0 (TeX Live 2015) (rev 5238)
> There is one latex file and 2 include .tex files and lots of math
> images. I have zipped the whole folder into one zip file. it is
> large (200 MB) so will take few minutes to download if someone
> wants to reprduce it. The zip file is here
>            http://12000.org/tmp/031416/
> called tangent_bug.zip
> The command to see the crash is:
> ----------------------------------
> lualatex report.tex
> .....
> (/usr/local/texlive/2015/texmf-dist/tex/latex/microtype/mt-msb.cfg)
> Package hyperref Warning: old toc file detected, not used; run LaTeX again (chee
> rs from etoc).
> (/usr/local/texlive/2015/texmf-dist/tex/latex/psnfss/t1pcr.fd)
> (/usr/local/texlive/2015/texmf-dist/tex/latex/psnfss/ts1pcr.fd) [1{/usr/local/te
> xlive/2015/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] [2] [3]
>      Segmentation fault (core dumped)
> -------------------------
> I tried to put all needed files in the zip file. So all what is needed
> is unzip the file and run the above command. If I missed some file,
> will update. Any other info needed, please let me know.
> thanks,
> --Nasser

More information about the luatex mailing list