[luatex] luaotfload in format file

David Carlisle d.p.carlisle at gmail.com
Sat Jan 9 12:18:42 CET 2016

hmm so the latex 2015/10/01 format defines the lua luatexbase table by
default, but the lua code is delayed until \everyjob as it can't be saved
in the format
so you end up loading luatotfload before luatexbase is defined which isn't

I think you want to end your ini file with



On 9 January 2016 at 11:06, David Carlisle <d.p.carlisle at gmail.com> wrote:

> On 9 January 2016 at 00:34, Reinhard Kotucha <reinhard.kotucha at web.de>
> wrote:
>> Hi,
>> when I run
>>   lualatex '\RequirePackage{luaotfload}\stop'
>> luaotfload is loaded without errors.
>> For a particular project I have to load luaotfload when the format
>> file is created.  This worked fine in the past.
>> Now I'm trying to make it work with TL2015.  I've updated the LaTeX
>> stuff in my .ini file but now I encounter a problem with luaotfload.
>> Here is a minimal example:
>> What error do you get, you don't say?
> I have updated luatex to luatex0.87 so the ini file as you have doesn't
> work at all (\pdfoutput not defined is the first error) but if I input a
> compatibility layer to define the \pdfxxx command names then the format
> builds from your makefile.   but with the  error
> luaotfload-main.lua:66: attempt to index local 'luatexbase' (a
>  nil value)
> stack traceback:
> is that what you see?
> I'll investigate that anyway but it would be good if you could confirm
> that is what you see
> David

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20160109/43a7679f/attachment.html>

More information about the luatex mailing list