[luatex] Using a Lua C .so module with LuaLaTeX

luigi scarso luigi.scarso at gmail.com
Mon Nov 16 17:14:16 CET 2015

On Mon, Nov 16, 2015 at 2:01 PM, luigi scarso <luigi.scarso at gmail.com>

> On Mon, Nov 16, 2015 at 1:13 PM, Deepak Jois <deepak.jois at gmail.com>
> wrote:
>> To narrow down the problem, I used the --luaonly option to run a test
>> lua file with luatex that loads the library. When I run:
>> luatex --luaonly test.lua
>> It gives me the error: Symbol not found: _luaL_setfuncs
>> Then, I built a fresh luatex binary from SVN using --nostrip option,
>> and ran the same thing, and it works fine.
>> I then tried to copy the freshly built luatex binary into TeXLive, and
>> ran fmtutil --all, but it gave me an error saying \pdfoutput was an
>> undefined control sequence.
>> So now I am wondering:
>> 1. Why does the luatex binary built from SVN with --nostrip work, and
>> the luatex binary bundled with TeXLive does not work when using in
>> --luaonly mode. Is that intentional? On StackExchange[1] there are
>> people on Linux who report that it working fine with TeXLive 2015 as
>> well. What is different about Mac OS X?
> I will check your code later under Linux.

with latest luatex underl linux

rm -rf *.o *.la *.lo .libs/
$CC -O2 -fpic -I$L -c harfbuzz.c
$CC -O -shared -fpic -o harfbuzz.so harfbuzz.o
$SVN/bin/luatex -luaonly test.lua


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20151116/1b2e48b7/attachment.html>

More information about the luatex mailing list