[luatex] Using a Lua C .so module with LuaLaTeX

luigi scarso luigi.scarso at gmail.com
Mon Nov 16 14:01:34 CET 2015

On Mon, Nov 16, 2015 at 1:13 PM, Deepak Jois <deepak.jois at gmail.com> wrote:

> To narrow down the problem, I used the --luaonly option to run a test
> lua file with luatex that loads the library. When I run:
> luatex --luaonly test.lua
> It gives me the error: Symbol not found: _luaL_setfuncs
> Then, I built a fresh luatex binary from SVN using --nostrip option,
> and ran the same thing, and it works fine.
> I then tried to copy the freshly built luatex binary into TeXLive, and
> ran fmtutil --all, but it gave me an error saying \pdfoutput was an
> undefined control sequence.

> So now I am wondering:
> 1. Why does the luatex binary built from SVN with --nostrip work, and
> the luatex binary bundled with TeXLive does not work when using in
> --luaonly mode. Is that intentional? On StackExchange[1] there are
> people on Linux who report that it working fine with TeXLive 2015 as
> well. What is different about Mac OS X?
I will check your code later under Linux.

> 2. How can I use the freshly built luatex binary with TeXLive 2015. Is
> there anything else I need to do before I run fmtutil --all so that
> this "undefined control sequence \pdfoutput" will go away.
> we are finishing the 0.85 release which is not compatible with  the
current lualatex format
(nothing dramatic).
But luatex --luaonly test.lua should work.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20151116/3526c2f9/attachment.html>

More information about the luatex mailing list