[luatex] [dev-context] Luatex 0.78.0 announcement

Mojca Miklavec mojca.miklavec.lists at gmail.com
Thu Jan 2 09:59:17 CET 2014

On Tue, Dec 31, 2013 at 8:26 PM, Taco hoekwater wrote:
>> Op 31 dec. 2013 om 20:17 heeft Mojca Miklavec het volgende geschreven:
>> Taco,
>> when building luatex I stumbled upon the attached problem. Do you have
>> any clue what I should check?
>> Metapost compiles just fine natively, but when cross-compiling, it
>> seems that it fails for some reason I don't understand.
>> Please let me know what I should check (last time I tried the whole TL
>> compiled fine, but I haven't checked for a while already).
> The cross-compiler is trying to build its own ctangle, which fails because ctangleboot in the build tree cannot find texmf.cnf. But, Afaik, it should not even try to build ctangle. Configure is supposed to check whether there is a working ctangle exe in PATH already. At least, that is what I remember.  But I cannot actually test anything on the ipad right now.

What I don't understand is why it cannot find texmf.cnf because the
file is there.

But anyway ... with some further manual compilation (simply running
"make" elsewhere in the tree after the failure) I somehow stumbled

Undefined symbols:
  "_fopen$UNIX2003", referenced from:

and http://www.cocoawithlove.com/2009/09/building-for-earlier-os-versions-in.html
suggested me to add
    -isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5

I thought the second argument was equivalent to
but apparently adding -mmacosx-version-min=10.5 solved the problem.

Please don't ask me how this was related to the failure to find texmf.cnf.


More information about the luatex mailing list