[luatex] METAPOST labels in Lualatex: illegal unit of measure

Jean Forget J2N-FORGET at orange.fr
Mon May 6 21:53:50 CEST 2013

Le lundi 06 mai 2013 à 17:09 +0900, Dohyun Kim a écrit :
> 2013/5/6 Jean <J2N-FORGET at orange.fr>:
> > Thank you for your help. I have downloaded your package, patched
> > luatexko-mplib.sty and installed the two files into the directory
> >      .../texmf-dist/tex/luatex/luamplib
> > that is, the same directory as luamplib.lua and luamplib.sty.
> > But the compilation failed because of :
> > ! LaTeX Error: File `luatexko-mplib.sty' not found.
> > I have tried creating a
> >      .../texmf-dist/tex/luatex/luatexko-mplib
> > directory and storing your two files into it, but the
> > result is the same. Is there any missing step in the
> > installation process?
> >
> It seems that you did not run 'mktexlsr'.
> Anyway, I don't recommend putting these files under texmf-dist
> directory. Above all they are for temporary or ad hoc solution. Why
> don't you put those files in the working directory, the same place as
> your tex source file?
Why didn't I put those files in the working directory? Because I did
not think of it. Because I still lack familiarity with the tex-live
directory architecture. Because I do not know if there is a tex-live
equivalent to the shell's $PATH. Because of many other reasons. 
Summing up: because PEBKAC (not always, but unfortunately too often).

Anyhow, I tried with luaexko-mplib.* in the working directory
and it works.

Since these files are public domain as you said in
does that mean that I can put them in a Github repo where I
have a LuaLaTeX + MetaPost file? (Asking just to be

> Best,
> --
> Dohyun Kim
> Seoul, Republic of Korea

Thank you,

Jean Forget

More information about the luatex mailing list