[luatex] luaotfload problems (MiKTeX/Windows 7) | not solved

Evan Cooch evan.cooch at gmail.com
Sat Jul 6 15:44:54 CEST 2013

> Run “luaotfload-tool --help”. Near the end it should print the
> cache paths, e.g.:
>      The font database will be saved to
>         /home/phg/src/texlive2013/texmf-var/luatex-cache/generic/names/luaotfload-names.lua
>         /home/phg/src/texlive2013/texmf-var/luatex-cache/generic/names/luaotfload-names.luc
>      <snip />
>      The font cache will be written to
>         /home/phg/src/texlive2013/texmf-var/luatex-cache/generic/fonts
> The path prefix (configured in texmf.cnf; in this case
> /home/phg/src/texlive2013/) must be writable for the user that is
> running luatex; the subdirectories under it will be created, even
> if you only run luaotfload-tool without options.

Well, perhaps a clue. When I run luaotfload-tool help, it shows me

The font database will be saved to:

and then...nothing else. I get no statement about where the font cache 
will be written to (i.e., I don't see anything like

The font cache will be written to

In fact other than the statements about where the font database will be 
written to, runing luaotfload-tool --help shows me nothing else. At all.

> nd all the subdirs contained therein).
> According to your log file that is where the font loader writes
> its cache files to:
>      C:/Users/egc/AppData/Local/MiKTeX/2.9/luatex-cache/generic/
> The names db should reside in a subdirectory “/names”, the font
> cache under “/fonts/”. If deleted, it will be recreated the next
> time you run luaotfload-tool or luatex with luaotload. Can you
> post the permissions of these directories and the files in them?

This might be the clue. If I delete luatex-cache from 
c:/users/egc/AppData/Local/MikTeX/2.9/ (i.e., start over), bring up a 
command shell, and then run

luaotfload-tool --update --force

It creates luatex-cache, then generic, and then names but...then quits 
with the following error message:

luatofload | db: scanning TEXMF and OS fonts...
luaotfload -tool: Windows API error 5: Access is denied.
luaotfload-tool: Data: C:/users/egc/Templates

and then it exits.

Now, whats odd is that I get the above if I run luaotfload-tool. But, if 
instead, I (i) delete the luatex-cache file (again, start over), and 
then try to compile a MWE that uses fontspec, it grinds along, then

luaotfload | db : Font name database not found, generating a new one.
luaotfload | db: This can take several minutes; please be patient.

and, as before, \fonts and \names get created, \fonts contains the 
fonts, but \names is empty.

So, even though I 'shouldn't', I bring up a cmd window, and as admin, 
run luaotfload-tool --update --force. Runs to completion. Fonts in 
\fonts, and (importantly) in \names, see luaotfload-names.lua and 

Now, try to compile MWE, and once again, I get all those ... could not 
write to cache messages. Document compiles, but still...

if it matters --

More information about the luatex mailing list