[luatex] luaotfload no longer finding fonts in TEXMF

Evan Cooch evan.cooch at gmail.com
Tue Jul 2 15:31:40 CEST 2013

Pre-recent updates to MikTeX 2.9, in order to allow luaotfload to 'find' 
fonts installed in TEXMF (say, XITS), especially (only?) if you 
installed for 'all users', you had to tweak lualibs-dir.lua, adding

P("(")  / "%%(" +
P(")")  / "%%)" +

around line around line 95, just before "P(1)". This worked perfectly.

After the updates, you (in theory) needed to tweak 2 files (around line 150 in the updated files)

lualibs-dir.lua (in tex\luatex\lualibs)

luaotflod-lib-dir.lua (in tex\luatex\luaotfload)

However, despite making these changes, luaotfload-tool doesn't seem to find the finds. If I run

luaotfload-tool --update --force --vvv

and watch things chug along, I can see it entering into (say the XITS subdirectory), but not finding any fonts, even though the fonts are actually there.

So, something isn't working. The fact that we need to hack things to get luaotfload to find the fonts in the first place seems problematic -- not sure why it isn't the default to escape ( and ) to let it find the fonts (although apparently that hack no longer works).

Suggestions? I can brute-force a solution by moving fonts from TEXMF to OS fonts directory (whereupon luaotfload-tool finds them just fine), but...I shouldn't have to.

More information about the luatex mailing list