[luatex] updates to various lua* packages breaks..something.

Philipp Gesang Philipp.Gesang at alumni.uni-heidelberg.de
Wed Apr 24 20:52:54 CEST 2013

···<date: 2013-04-24, Wednesday>···<from: Evan Cooch>···

> On 4/24/2013 4:49 AM, Philipp Gesang wrote:
> >···<date: 2013-04-23, Tuesday>···<from: Evan Cooch>···
> >
> >>First time posting to this list. Apologies if posts 'like this'
> >>should go somewhere (or to someone) else.
> >>
> >>After most recent (23 Apr) updates (I'm using MikTeX 2.9) to various
> >Which most recent update are you talking about? Could you please
> >add the output of mkluatexfontdb -V ?
> mkluatexfontdb version 1.07, database version 2.009


> But, it doesn't matter. I normally use Minion Pro (which I own), but
> it fails even using XITS  Here is a simple MWE
> <snip />

Thanks for the example. I can confirm those unwanted updates when
fontspec includes the euenc definitions (lm).

> When I try to compile this using lualatex (using MikTeX 2.9),  it
> absolutely refuses to compile. For this MWE, the error message
> actually occurs during liaotfload:
> Luaotfload | scanning TEXMF and OS fonts...lualatex: Unexpected condition.
> And then it stops.

Afaics this is not a luaotfload error.

> >>Compilation itself does seem to progress 'correctly', but something
> >>that takes twice as long (because of what appears to be a bug
> >>causing luaotfload to run every time a file is compiled, is not an
> >>'update'.
> >Probably an incorrect "file:" lookup.
> Meaning?

It is under investigation:


> >>Wonder if its related to the following. If I bring up an admin cmd
> >>console, and run
> >>
> >>mkluatexfontdb -f -vvv
> >>
> >>I get an error:
> >>
> >>mklualatexdb: Windows API Error 5: Access is denied
> >>mklualatexdb: Data: C://Documents and settings
> >Sorry, no idea. Maybe you need to pass it to texlua?
> Sorry, but that seems like a stretch.  Everything worked before
> worked before.

I can’t test with windows but it would appear this is permissions
related. Run mkluatexfondb -h to see where the database is
located. You need write permissions in that directory.

> >>Suggestions? Clearly something has been 'broken' during the update -
> >>at least on Windows machines running MikTeX 2.9.
> >>
> >>Thanks in advance.
> >Thanks for reporting
> >Philipp
> Sure -- not sure what else to report.
> I think the fact that mkluatexfontdb doesn't run - at all really -
> is telling. Could it be a corruption of something on this one -
> updated - system? Suggestions on what to look for?

File permissions. If the database is being rebuilt over and over
again, this might be a clue that it cannot be saved to disk. The
message indicating this would be:

  luaotfload | Font names database not found, generating new one.

If it is only updated, then it’s a problem with the lookup. In
this case, the message is the one you gave in your first post:

  luaotfload | Updating the font names database:

If you are feeling adventurous, you can locate the file
“luaotfload.lua” from your distribution. Make a backup and
then comment out the line:

  fonts.define.resolvers.file = fonts.define.resolvers.name

and see if it helps.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://tug.org/pipermail/luatex/attachments/20130424/24ba0465/attachment.bin>

More information about the luatex mailing list