[luatex] Attempt to build font name database fails with app crash

Dieter Köhler dieter.koehler at philo.de
Sun May 6 19:16:59 CEST 2012

Thank you, Ulrike for you explanation!!!

After discovering the problematic font, it took  me still some time to 
figure out, how to add it to the black list.  So just for the archives, 
here is what I needed to figure out:

After running "mkluatexfontdb -v" as adviced I found out at which font 
mkluatexfontdb crashed.  So I needed to blacklist the font in question. 
For this purpose the luaotfload manual advised me to create a 
otfl-blacklist.cnf file and put it somewhere where "kpse" (whatever this 
is?) can find it.  I first thought: Pehaps I should put the file in the 
same directory as mkluatexfontdb.exe.  But then I found out that there 
is already an otfl-blacklist.cnf file in my MiKTeX Windows installation 
in the "tex/luatex/luaotfload" subdirectory. It had already some 
blacklisted fonts in it.  So I appended the fontname including the file 
extension to it.  However, mkluatexfontdb still tried to process the 
font in question.  After some laborious experiemnts I discovered the 
reason of it: The fontnames in the blacklist need to be normalized to 
lower-case.  And I also discovered that, if I use complete paths, the 
back-slashes needs to be normalized to forward-slashes. After adding the 
fontname (including its file extension) in lower-case to 
otfl-blacklist.cnf, building the fontname database finally worked!

Dieter Köhler

Am 06.05.2012 15:55, schrieb Ulrike Fischer:
> Am Sat, 5 May 2012 23:13:41 +0200 schrieb Dieter Köhler:
>> Hi all,
>> When I use the \setmainfont{} command from the fontspec package,
>> lualatex crashes while attempting to build a font name database.
>> The last lines from the log are:
>>> luaotfload | Font names database not found, generating new one.
>>>               This can take several minutes; please be patient.
>>> luaotfload | Updating the font names database:
>>> luaotfload | Scanning TEXMF and OS fonts...
>> A few seconds after this output lualatex.exe crashes. These are the
>> details from the crash report:
>> I am using an up-to-date MiKTeX installation on Windows Vista. MiKTeX is
>> installed in the "Program Files" directory. And I am running lualatex as
>> user, not an admin.
> Run on a command line
> mkluatexfontdb -v
> If it stops/crashes at a font, try if it works if you add this font
> to the blacklist. See the documentation of luaotfload for details.

More information about the luatex mailing list