[luatex] Plain TeX is not working

Taco Hoekwater taco at elvenkind.com
Sat May 9 09:24:51 CEST 2009

Yue Wang wrote:
> Hi, Hans:
> I am using the ConTeXt minimal distribution to run plain TeX.
> The ini file is exactly same as your luatex-plain.tex.
> However, I run into this problem:
> This is LuaTeX, Version beta-0.40.0-2009042221 (Web2C 7.5.7)
>  \write18 enabled.
> (test.tex (c:/context/tex/texmf-context/tex/generic/context/luatex-basics.tex)
> (c:/context/tex/texmf-context/tex/generic/context/luatex-fonts.tex
> <luatex-fonts-merged.lua> <luatex-fonts.lua loaded in 0.047 seconds>)
> (c:/context/tex/texmf-context/tex/generic/context/luatex-mplib.tex)
> ! LuaTeX error ...-context/tex/generic/context/luatex-fonts-merged.lua:5124:
> attempt to index global 'caches' (a nil value).
> <to be read again>
>                    \testa
> l.1 ...n10-regular                  at 12pt \testa
>                                                    \input tufte \par
> ?
> My test file is attached here:
> \font\testa=file:lmroman10-regular                  at 12pt \testa

As far as I know, luatex-fonts only supports xetex-style font names.

Have you tried


Best wishes,

More information about the luatex mailing list