[lltx] luaotfload update

Ulrike Fischer news3 at nililand.de
Thu Oct 6 17:39:10 CEST 2011

Am Thu, 6 Oct 2011 17:22:06 +0200 schrieb Khaled Hosny:

>> Do you know why   "sub a b by c;" works fine (2 glyphs mapped to one
>> glyph) while  "sub d by e;" (one to one) fails?
> Are they both in the same feature/lookup block, if so then I recall it
> is a bug in FontForge feature file import (one too many and one to one
> are different internally and need to go to separate lookups, FontForge
> should either complain and reject the file or do the split, but it seems
> to just silently ignore the different entries. Moving each type to its
> own block should fix it.)

Yes, using a second feature "tsim" worked. 

>>>> Comments:
>>>> 1. You must delete the temp-arial-tex-dash.lua etc files in the
>>>> luatex-cache after you changed the fea-file or you won't see the
>>>> changes.
>>> I don't need this here, I recall this being fixed for some time now.
>> Yes I also recall that at some time it worked. But currently it
>> doesn't work for me. I have to delete the temp-files. 
>> How does luaotfload decide if the temp-files should be regenerated?
> The cashed file name is a hash for font name and any applied feature
> files, here I have in my cache temp-dejavusans.lua and
> temp-dejavusans-tex-dash.lua.

I too have the two lua files. But if I change something in the fea
file, e.g. add another sub command, - *without changing the name of
the file* - temp-arial-tex-dash.lua is not recreated and the new sub
command is ignored.  

Ulrike Fischer 

More information about the lualatex-dev mailing list