[lltx] problem with luamplib from TL2010 (pretest)

Ulrike Fischer news3 at nililand.de
Tue Sep 14 10:03:58 CEST 2010

Am Mon, 13 Sep 2010 20:24:52 +0300 schrieb Khaled Hosny:

>> Well I do have luamplib version 1.04 which avoids this error (it
>> should be \directlua instead of \luadirect I think) but now gives
>> another error with luatex and lualatex:
>> ! LuaTeX error j:/MIKTEX2.7/tex/luatex/luamplib/luamplib.lua:74: bad
>> argument #2 to 'format' (string expected, got nil)
>> stack traceback:
>> [C]: in function 'format'
>> j:/MIKTEX2.7/tex/luatex/luamplib/luamplib.lua:74: in function 'log'
>> j:/MIKTEX2.7/tex/luatex/luamplib/luamplib.lua:124: in function
>> 'load'
>> 	j:/MIKTEX2.7/tex/luatex/luamplib/luamplib.lua:170: in
>> function 'process'
>> 	<\directlua >:1: in main chunk.
>> \mplibprocess
>> ...ectlua {luamplib.process([[#1]])}

> I can't reproduce this, but indeed `luamplib.finder()` is returning
> nil. May be you need to run `luamplib-createmem.lua` script to create a
> mem file, seems miktex does not provide one by default.

It is naturally possible that it is a problem with my installation,
as it is partly miktex partly a mini texlive. But the documentation
says that a mem is not actually needed and it worked last time I
tried (end of july). 

Also I just saw that the same error is mentioned two threads below
(8. August) where Taco mentioned that some code should be added to

Like mentioned there I too can't create a mem with the lua script,
it tells me "dumping format plain in mplib-luatex.mem" but no file
is generated. 

My luatex version is currently beta-0.62.0-2010081917. 

Ulrike Fischer 

More information about the lualatex-dev mailing list