[lltx] [fontspec] selecting font features has no effect?

Diederick C. Niehorster dcnieho at gmail.com
Wed Mar 31 04:18:27 CEST 2010

Hi Élie,

On Tue, Mar 30, 2010 at 8:25 PM, Élie Roux
<elie.roux at telecom-bretagne.eu> wrote:
> 2010/3/30 Diederick C. Niehorster <dcnieho at gmail.com>:
>> ! LuaTeX error ...9/texmf-dist/tex/luatex/luaotfload/otfl-font-nms.lua:76: atte
>> mpt to compare nil with number.
> Interesting... I'll take a look at it soon, I hope I'll have time...

Ok, see the other message for tests with the updated lualoadotf and
find my otfl-names.lua attached (note that this otfl-names.lua is not
made with the most up to date luaotfload, see below).

>> I thus seem to have multiple weird problems (this and the
>> mkfontnamedb.lua silently dying in the middle of its operation when
>> the --sys switch is given) with otfl,
> This is actually weird, I'll try to reproduce it, but it doesn't seem easy...

Hmm, its getting more consistent. Right now, it silently stops
processing at the same point, no matter whether --sys is provided or
not. See the attached logs (which are almost exactly the same, i ran a
diff on them).

Hmm, just tried again, now it did go through sees _sys2 in the zip.. Weird!
I can send you any fonts if that would help.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: log_nosys.zip
Type: application/zip
Size: 20316 bytes
Desc: not available
URL: <http://tug.org/pipermail/lualatex-dev/attachments/20100331/bd569924/attachment.zip>

More information about the lualatex-dev mailing list