[l2h] latex2html-2015 problems: chdir to home directory, Illegal seek

Gavin Smith gavinsmith0123 at gmail.com
Wed Feb 17 08:36:15 CET 2016

I downloaded and installed the latex2html-2015 release. latex2html
--version reports

This is LaTeX2HTML Version 2008 (1.71)
by Nikos Drakos, Computer Based Learning Unit, University of Leeds.

I've tried running it like this: latex2html -dir . -address 0 -info 0
-split 0 -no_navigation -no_auto_link -prefix rawhtml_l2h_

The input file has the following contents:

% This document was automatically generated by the l2h extenstion of texi2html

<!-- l2h_begin rawhtml_l2h 1 -->
<!-- l2h_end rawhtml_l2h 1 -->


There are at least two problems that seem to appear with this:
* The chdir Perl command is passed an empty string which means it
changes to my home directory ("/home/g") instead of the directory
where the input fie is.
* Error running pnmcrop - an "Illegal seek" error occurs.

pnmcrop appears to be run by "gs". I tried upgrading ghostscript to
9.18, but it made no difference.

pnmcrop -version reports:

pnmcrop: Using libnetpbm from Netpbm Version: Netpbm 10.49.2
pnmcrop: Compiled Tue Feb 16 14:42:11 CST 2010 by user "root"
pnmcrop: BSD defined
pnmcrop: RGB_ENV='RGBDEF'
pnmcrop: RGBENV= 'RGBDEF' (env vbl is unset)

Please ask me to report any other versions of programs if it could be
relevant to this problem.

Full output below:

$latex2html -dir . -address 0 -info 0 -split 0 -no_navigation
-no_auto_link -prefix rawhtml_l2h_ ./rawhtml_l2h.tex
This is LaTeX2HTML Version 2008 (1.71)
by Nikos Drakos, Computer Based Learning Unit, University of Leeds.

Revised and extended by:
 Marcus Hennecke, Ross Moore, Herb Swan and others
...producing markup for HTML version 4.0

Extension: loading /usr/local/share/lib/latex2html/versions/latin1.pl
HTML version: loading /usr/local/share/lib/latex2html/versions/html4_0.pl

 *** processing declarations ***

OPENING /home/g/src/texinfo/PROJ_SVN/tp/rawhtml_l2h.tex

Cannot create directory ./: File exists, reusing it.
Use of chdir('') or chdir(undef) as chdir() is deprecated at
/usr/local/share/lib/latex2html/L2hos/Unix.pm line 250.

Note: Working directory is /home/g
Note: Images will be generated in /tmp/l2h7172

texexpand V2008 (Revision 1.12)

Loading /usr/local/share/lib/latex2html/styles/texdefs.perl...
Package: loading /usr/local/share/lib/latex2html/styles/article.perl
Package: loading /usr/local/share/lib/latex2html/styles/html.perl
Reading ...

Translating ...
0/0:top of rawhtml_l2h: for rawhtml_l2h.html

 *** translating preamble ***
 *** preamble done ***

Writing image file ...

This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.

 *** processing 1 images ***

Generating postscript images using dvips ...
This is dvips(k) 5.95a Copyright 2005 Radical Eye Software (www.radicaleye.com)
' TeX output 2016.02.17:0732' -> /tmp/l2h7172/image
(-> /tmp/l2h7172/image001) <tex.pro><alt-rule.pro><texps.pro><special.pro>
Converting image #1
pstoimg: Error: "/usr/bin/pnmcrop -verbose  < /tmp/l2h7172/p7196.pnm |
/usr/bin/pnmcrop -verbose  -bot -sides  -black  | /usr/bin/pnmcrop
-verbose  -l -sides  -black   > /tmp/l2h7172/p7196.t00" failed:
Illegal seek

Error while converting image

Error: Cannot read 'rawhtml_l2h_img1.png': No such file or directory

Doing section links ....

*********** WARNINGS ***********

Failed to convert image /tmp/l2h7172/image001.ps

To resolve the image conversion problems please consult
the "Troubleshooting" section of your local User Manual
or read it online at


More information about the latex2html mailing list