[l2h] TMP strikes again! TMP folder blues with latex2html on windows

Nasser M. Abbasi nma at 12000.org
Mon Apr 12 01:40:53 CEST 2010

thanks Ross, I will try the things you said below and see what I find.

I just to say that this is the SAME drive, same data, the same latex file. 
Nothing changed. I am simply running l2h on the same tex files, which worked 
OK when the drive was attached to the desktop PC. I moved the desk to the 
laptop, and setup what I think the same exact env. for l2h on the laptop 
(same drive letter, same software versions, env. variables, etc..). I did 
not change the data at all.

They are the same images, same tex files, which all was working OK before. 
i.e. being processed OK and had generated HTML pages from them ok.

So, there is something different on the laptop env. for l2h.  I'll try to 
un-install everything again, and install everything one more time also.

<rant>This is the hard part about using l2h, getting it to work OK on 
windows, I thought I sorted this mess out, but I am overlooking something it 

I am assuming on Linux, life with l2h and pnm tools is much more peaceful. 
If someone can make a tool to automatically configure and install l2h on 
windows with all the needed auxiliary software, they can probably make a 
million dollars ;)
</end rant>


----- Original Message ----- 
From: "Ross Moore" <ross at ics.mq.edu.au>
To: "Nasser M. Abbasi" <nma at 12000.org>
Cc: "Latex2Hmtl list" <latex2html at tug.org>
Sent: Sunday, April 11, 2010 4:24 PM
Subject: Re: [l2h] TMP strikes again! TMP folder blues with latex2html on 

> On 12/04/2010, at 5:12 AM, Nasser M. Abbasi wrote:
>> I get this error when I run latex2html on a tex file:
>> "Error: Cannot read 'img62.png': No such file or directory
>> Converting image #33
>> pstoimg.bat: Error: Ghostscript returned error status 16777215
>> pstoimg.bat: Error: Couldn't find pnm output of G:\LATEX\TMP\l2h288 
>> \image033.ps"
>> I never seen error 16777215. I've seen this error below before. It  seems 
>> to be coming from pnmcrop.exe, please see error messages  below. It seems 
>> to be looking for files with names such as p2668.t01
> No; the error is occurring whilst failing to create  p2668.t01  ...
>> in the TMP folder where images are processed. But when I look in  the TMP 
>> folder, I see no such files, but ones extensions .t00 (next  to .pnm and 
>> .ps files).
>> =============== screen log ==========
>> $latex2html -debug -verbosity 8 -split 0  -no_reuse - 
>> show_section_numbers EE_409_HW7.tex
>> pstoimg.bat: Running \LATEX\gsAFLP\gs8.54\bin\gswin32c.exe  - 
>> sDEVICE=ppmraw -g675x68  -r115 -dTextAlphaBits=4  -sOutputFile=G: 
>> \LATEX\TMP\l2h2
>> 228\p2668.pnm
>> GS>-57 -679 translate
>> GS>(G:/LATEX/TMP/l2h2228/image032.ps) run
>> GS>showpage
>> GS>quit
>> AFPL Ghostscript 8.54 (2006-05-17)
>> Copyright (C) 2005 artofcode LLC, Benicia, CA.  All rights reserved.
>> This software comes with NO WARRANTY: see the file PUBLIC for details.
>> GS>GS>>>showpage, press <return> to continue<<
>> GS>>>showpage, press <return> to continue<<
>> GS>
>  Ghostscript finished fine here, supposedly creating  p2668.pnm .
> Having used -debug  you should be able to look at this image
> in some graphics programs. If not, then try to find the
> correct page in  images.ps , using GSview say.
> Aside:
> It would be better if there were an extra \n (<return> character)
> in the output log, at this point.
>> Running "G:\LATEX\GnuWin32\bin\pnmcrop.exe -verbose   < G:\LATEX\TMP 
>> \l2h2228\p2668.pnm > G:\LATEX\TMP\l2h2228\p2668.t01"
>> pstoimg.bat: Error: "G:\LATEX\GnuWin32\bin\pnmcrop.exe -verbose   < 
>> G:\LATEX\TMP\l2h2228\p2668.pnm > G:\LATEX\TMP\l2h2228\p2668.t01"  failed:
>> No such file or directory
> This kind of failure occurs when the .pnm  image has been
> cropped away completely, leaving nothing behind.
> Look at the .pnm file.
> Do you see any of the contents that you expected to be there?
> Or is it a completely blank page?
>  --- if blank, then that certainly explains the error.
> Are there other images in the same document, occurring after
> this one? Do they have the correct content?
> If not, then maybe you have an oversized image, causing
> an extra page in the LaTeX run on images.tex.
> This will cause images to get out of synch. and the extra
> blank page (not the final page) will cause at least one
> on the image-generation steps to fail, as you seem to have here.
>> Error while converting image
>> *** Warning:
>> Failed to convert image G:\LATEX\TMP\l2h2228\image032.ps
>> extracted tex2html_wrap_indisplay453 as 32
>> embedding img32.png for tex2html_wrap_indisplay453, with ALT="$ 
>> \displaystyle =\left( \frac{1}{s+1}-\frac{1}{s+2}\right) +\left ( 
>> \frac{1}{2}<t
>> e...
>> ...>45 \frac{e^{-s}}{s}-\frac{e^{-s}}{s+1}+\frac{1}{2}\frac{e^{-s}} 
>> {s+2}\right) %
>> $"
> This looks like a very long line of input for inline-math.
> So long, in fact, that part of it has been removed
> for creating the ALT tag.
> It can certainly lead to a too-large image --- too wide.
> But more than this, the place where the cut occurs:
>     <te... ...>45
> looks like the remnant of a LaTeX2HTML internal tag that
> has not been replaced during the processing.
> So something has going quite wrong with the LaTeX content.
> To find out what, simply manually run LaTeX on  images.tex
> and have a look at the images. Or use GSview  with the
> images.ps  file that you should already have.
> The fact that there is a problem will just jump out at you.
> How to fix it? That's a different matter.
> But once having found where it occurs, the kind of rewrite
> to your source should be reasonably easy to find.
>> Error: Cannot read 'img32.png': No such file or directory
>> *** image done ***
>> ======= end of screen log =======
>> I'll keep looking, but if someone have seens this error message,  and 
>> have a clue, please let me know.
>> Thanks!
>> --Nasser
> Hope this helps,
> Ross
> ------------------------------------------------------------------------
> Ross Moore                                       ross at maths.mq.edu.au
> Mathematics Department                           office: E7A-419
> Macquarie University                             tel: +61 (0)2 9850 8955
> Sydney, Australia  2109                          fax: +61 (0)2 9850 8114
> ------------------------------------------------------------------------

More information about the latex2html mailing list