[l2h] Why images cannot be generated?

hooklee hooklee@sina.com
Wed, 18 Dec 2002 11:6:41 +0800

Dear Ross Moore,

Thanks for your help. Stragely, it seems that config.bat have successfully find AFPL Ghostscript 8.00. The following is the segmented texts in config.log after running config.bat:

checking for gswin32c... C:\gs\gs8.00\bin\gswin32c.exe
checking for ghostscript version... 8.00

Similarly, the following is the segmented texts in pstoimg.bat after running install.bat:

# Ghostscript
my $GS = 'C:\\gs\\gs8.00\\bin\\gswin32c.exe';
my $GSDEVICE = 'pnmraw';
my $GSALIASDEVICE = 'ppmraw';

AFPL Ghostscript 8.00 is the latest version of AFPL Ghostscript, which can be downloaded at http://www.cs.wisc.edu/%7Eghost/doc/AFPL/get800.htm. I installed the win32 version of AFPL Ghostscript 8.00, and the right command corresponding to "gs" is "gswin32c". The followings are the display of "gswin32c -v" and "gswin32c --help":

C:\>gswin32c -v:
AFPL Ghostscript 8.00 (2002-11-21)
Copyright (C) 2002 artofcode LLC, Benicia, CA.  All rights reserved.

C:\>gswin32c --help:
AFPL Ghostscript 8.00 (2002-11-21)
Copyright (C) 2002 artofcode LLC, Benicia, CA.  All rights reserved.
Usage: gs [switches] [file1.ps file2.ps ...]
Most frequently used switches: (you can use # in place of =)
 -dNOPAUSE           no pause after page   | -q       `quiet', fewer messages
 -g<width>x<height>  page size in pixels   | -r<res>  pixels/inch resolution
 -sDEVICE=<devname>  select device         | -dBATCH  exit after last file
 -sOutputFile=<file> select output file: - for stdout, |command for pipe,
                                         embed %d or %ld for page #
Input formats: PostScript PostScriptLevel1 PostScriptLevel2 PostScriptLevel3 PDF

Available devices:
   display mswindll mswinpr2 epson eps9high eps9mid epsonc ibmpro deskjet
   djet500 laserjet ljetplus ljet2p cdeskjet cdjcolor cdjmono cdj550
   uniprint djet500c declj250 lj250 st800 stcolor bj10e bj200 t4693d2
   t4693d4 t4693d8 tek4696 pcxmono pcxgray pcx16 pcx256 pcx24b pcxcmyk pbm
   pbmraw pgm pgmraw pgnm pgnmraw pkmraw tiffcrle tiffg3 tiffg32d tiffg4
   tifflzw tiffpack bmpmono bmpgray bmp16 bmp256 bmp16m tiff12nc tiff24nc
   psmono bit bitrgb bitcmyk pngmono pnggray png16 png256 png16m jpeg
   jpeggray pdfwrite pswrite epswrite pxlmono pxlcolor bbox ljet3 ljet3d
   ljet4 ljet4d pj pjxl pjxl300 jetp3852 r4081 lbp8 m8510 necp6 bjc600
   bjc800 pnm pnmraw ppm ppmraw spotrgb spotcmyk devicen bmpsep1 bmpsep8
   bmp32b psdcmyk psdrgb nullpage
Search path:
   . ; C:\gs\gs8.00\lib ; C:\gs\fonts ; c:/gs/gs8.00/lib ; c:/gs/fonts
For more information, see c:/gs/gs8.00/doc/Use.htm.
Report bugs to bug-gs@ghostscript.com, using the form in Bug-form.htm.

best regards,
Shujun LI

>> Hi all,
>> I download the latest version of latex2html from www.latex2htm.org, but I encountered strange problem when I run test.bat after running config.bat. The problem is: all images, including the ones generated to display complex equations, cannot be displayed in the html pages. The report is as follows:
>> Converting image #2
>> pstoimg.bat: Error: Ghostscript returned error status 0
>> pstoimg.bat: Error: Couldn't find pnm output of C:\ChinaTeX\Temp\l2h1624\image002.ps
>> Error: Cannot read 'img2.gif': No such file or directory
>> Although it seems that I have not correctly installed Ghostscript, I really installed the latest version (Ghostscript 8.00) and set "$prefs{'EXTRAPATH'} = 'C:\\gs\\gs8.00\\bin';" in prefs.pm before I ran config.bat.
>Hmm; I've never seen Ghostscript 8.
>Can you please show me what message results from the following commands:
>  gs -v
>  gs --help
>    (just the first few lines, please)
>> If I omit the problem and continue to run install.bat, the problem remains when I try to translate any .tex file to html documents.
>I'm guessing that the full path to Ghostscript was not found when you installed
>LaTeX2HTML. There should be a message about this in the configure log.
>This means that some variables, name $GS and starting $GS... will have empty
>values instead of full directory paths. 
>You could try to find these and fix them, or wait until the installer is patched
>to recognise this latest version of Ghostscript.
>Hope this helps,
>	Ross Moore
>> Shujun Li
>> E-mail: hooklee@sina.com hooklee@mail.com
>> Institute of Image Processing
>> School of Electronics & Information Engineering
>> Xi'an Jiaotong University
>> Xi'an, Shaanxi 710049, P. R. China
>> My home page: http://www.hooklee.com
>> Welcome to visit ChinaTeX: http://www.ctexer.net
>> _______________________________________________
>> latex2html mailing list
>> latex2html@tug.org
>> http://tug.org/mailman/listinfo/latex2html