[l2h] Getting latex2html to run on Amiga

Martin Steigerwald Martin.Steigerwald@gmx.net
19 Mar 2001 14:10:37 +0100


last year I wrote my diploma thesis with PasTex 1.4.1 and LaTeX on my
Amiga. Worked like a charm.

Now I finally come around into looking how to get this LaTeX document into
HTML. Before trying it by hand or via some ARexx script I write, I thought
it is better to look into an existing solution. Norbert Roth told me of
latex2html, so I downloaded:


I edited prefs.pm. AFAIR I changed only one option that says where the
latex2html should be located on the server and left everything else as it
is as I have a working GeegGadgets unix alike environment set up on my
Amiga (see http://www.ninemoons.com, AFAIK, maybe server changed
recently). After this I ran a "sh" (ksh actually") and typed


This went almost till the end, but then it failed, or at least it did not
write out a Makefile:

# ./configure
creating cache ./config.cache
checking for perl... /gg/bin/perl
checking whether #! works in shell scripts... yes
launching proprietary configuration...

config.pl, Release 99.2beta8 (Revision 1.32)
Accompanies LaTeX2HTML, (C) 1999 GNU Public License.

checking for old config file (cfgcache.pm)... loaded
checking for platform... amigaos (assuming unix)
checking for /gg/bin/perl... /gg/bin/perl
checking perl version... 5.00502
checking if perl supports some dbm... yes
checking if perl globbing works... yes
checking for tex... no
checking for latex... no
Warning: Will not be able to generate images due to above failure.
checking for kpsewhich... no
checking for TeX include path... NONE
Warning: Will not automatically install LaTeX2HTML style files.
checking for html4-check... no
checking for gs... no
Warning: Will not be able to generate images due to above failure.
checking if multiple pipes work... yes
checking for temporary disk space... /tmp
creating cfgcache.pm
Note: Will install...
      ... executables to   : /usr/local/bin
      ... library items to : /usr/local/lib/latex2html
updating cache ./config.cache
creating ./config.status
sed: can't read conftest.subs: No such file or directory

If everything went well,  you may run 'make'

The only thing that really failed is "sed" here. Okay, it didn't found
LaTeX, TeX or GS - well they are installed here, but at Amiga-ish
locations and not within the GG unixish filesystem structure. I didn't
bother to point it to the right locations, since my tex file does not
contain tables or images.

Anyone has an idea an how I can fix this up? Do you need further
informations? Well I guess you won't have that many Amiga latex2html
users, but maybe we can get this problem sorted out anyhow?

Martin 'Helios' Steigerwald  - http://helios.home.pages.de
PGP: http://home.pages.de/~helios/autor/wie-erreichen.html
ICQ: #34355756