[l2h] 99.1beta8 on Win98 - problems and solution

Martin Wolf Martin Wolf" <mw7@stud.mw.tu-muenchen.de
Thu, 28 Sep 2000 08:21:37 +0000 (GMT)

Hello out there!
I just tried to install LaTeX2HTML 99.1beta8 on an Win98 computer -- and failed.
Because I really need it and had an onter installation running under Win95, 
I tried to discover the problems. So I spend one day and locatet the two following:

***** FIRST *****
problem: config won't be able to discover the dvips-version of MikTeX 1.20e.
         it also failed in recognizing the ability of pnmcrop recognizes the -l switch
cause  : analyzing the config.pl I realized, that the get_out_err subroutine 
         delivers $stat=-1 although the called command finishes without error.
         the reason why is a PERL BUG, occuring in ActivState Perl 5.6.0 Build 611 I had installed.
         consulting the perl bug database, the bug seemed to stay until Build 616.
         Whether earlier versions are also buggy I don't know. 
solution:With the new version Build 618 everything works fine. Perhaps a hint could be 
         added in the Install file, as this is really difficult to find.

***** SECOND *****
problem: config.pl wasn't able to recognice version-number of Ghostscript 6.0 as
         described earlier on this list, although it should. As the workaround of 
         manually setting of the version number is not so nice, looked for the
cause  : In opposite to earlier versions of GS (I had a 3.33), gswin32c -h prints in the first
         line "Aladdin Ghostscript 6.0 (2000-02-03)" on the terminal, the perl script
         is only able to get "6.0 (2000-02-03)". (Why??) So config.pl is not able to find the 
         "Ghostscript" in front of the version number. 
solution:I would suggest a change of line 987 (as workaround or generally)
         from: if($flag == 0 && /Ghostscript\s*(?:Version|BETA RELEASE|TESTER RELEASE|)\s*(\d+[.]?\d*)/i) {
         to:   if($flag == 0 && /(?:Ghostscript\s(?:Version|BETA RELEASE|TESTER RELEASE|)\s*|^)(\d+[.]?\d*)/i) {

So, now the installation works fine. I hope, that is a little bit useful


PS: To make it easier for MikTeX-users, could line 857 generally be chaned?
    from:  @tryopts = ('','--version','-?','-v');
    to:    @tryopts = ('-v','--version','-?','');

   ##           ##     Martin Wolf
  ####          ##     München, Germany
 ## ##   ##    ##      +49 89 36 16 009
##  ## # ##  ##        <martin@familiewolf.de>
##    ##  ####         http://www.familiewolf.de