[l2h] Re: l2h on linux

taupin taupin <taupin@lps.u-psud.fr>
Thu, 02 Sep 1999 09:57:06 +0200



Marek Rouchal wrote:
> 
> On Sun, 29 Aug 1999, taupin wrote:
> 
> > 1. As I have installer Linux on a part of my new PC, I ask: does
> > latex2html work easily on linux? (I seem to have perl and GhostScript)
> 
> It probably works *best* on Linux :-)
> Seriously: Recent Linux distributions have everything in place you need
> for LaTeX2HTML. There should be no installation problems.

Yes, there was a dummy problem: I tried to find in my installation (and
in RedHat distrib 5.2) a file of the form *netpbm* and there aw none,
therefore I asked Marek to point me to f netpbm.p1 distribution. I got
it but "make -f Makefile.std" failed because there was NO libtiff.

Therefore I found a libtiff source and its "make -f Magefile.gcc" failed
with a lot of errors (and did not generate libtiff.a).

Desperately, I found a lintiff-*i386.rpm in RedHat distrib 5.2 and I
rpm-ed it successfully and copied it as a subdirectory of netpbm root
directory. However the general Makefile of netpbm still failed for a lot
of reasons. Since I also had that problem when imprementing netpbm.p2
for non-piping systems (or badly piping) I tried to "make" the subdirs
of netpbm, and my first trial "netpbm.../pbm" did work. I installed the
executables in /usr/local/bin

Then I looked with a "find" command to locate the generated executables
and be sure of their unicity (usual trick) and I was astonished to find
the netpbm executables... already in /usr/bin, i.e. installed with the
RedHar distribution! However, I have not yet tested whether if is the
".p1" version of not. Because of what follows.
> 
> > 2. (since I have disconnected for more than one year), where can I find
> > the mode recent distribution of latex2html at present time?
> 
> http:://saftsack.fs.uni-bayreuth.de/~latex2ht

Got it and installed it without problem. My only installation criticism
is that the README says that one has to install NETPBM, and does not
give a hint to check whether it is or not already.

But when I tried to convert some LaTeX file, there was no image
generation and the "images.log" file contains:
> 
> Cheers,
> 
> Marek
> 
> ********************************************************************
> * Marek Rouchal <marek.rouchal@gmx.net>                            *
> * !!! please use only this address, set in the Reply-To header !!! *
> ********************************************************************
This is TeX, Version 3.14159 (Web2C 7.2) (format=latex 1998.10.11)  2
SEP 1999 09:25
**./images.tex
(./images.tex
LaTeX2e <1998/06/01>
Babel <v3.6j> and hyphenation patterns for american, french, german,
italian, n
ohyphenation, loaded.

(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 1998/05/05 v1.3y Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo
File: size10.clo 1998/05/05 v1.3y Standard LaTeX file (size option)
)
 ...
\bibindent=\dimen102
) (/usr/share/texmf/tex/a-win95d/html.sty
Package: html 1998/06/21 v1.31 hypertext commands for latex2html (nd,
hws, rrm)

 ...
\sizebox=\box26
\lthtmlwrite=\write4
(images.aux
-34- this file and other auxiliary files require to use the following
-34- LaTeX packages: french!
-34- check \usepackage or remove these files.Typesetting is aborted!
 ) )
(\end occurred inside a group at level 2) 
Here is how much of TeX's memory you used:

Clearly, this diagnostic does not occur with the 98.1p7 I have under DOS
on the same computer.

==> Explanation, please. And how to bypass that trick?
-- 

------------------------------------------------------------------------
  Daniel Taupin, Physique des Solides, Univ. Paris-Sud, 91405 ORSAY
  E-mail= mailto:taupin@lps.u-psud.fr
  TÚl: (33)1.69.15.60.79, Fax: (33)1.69.15.60.86, home/fax:
(33)1.60.10.26.44

------------------------------------------------------------------------