[texworks] LaTeXmk issue with Mac OS X Yosemite (new OS)

Guillaume Cabanac guillaume.cabanac at univ-tlse3.fr
Sun Oct 19 16:26:12 CEST 2014

Dear Herbert,

> The method you used to avoid the long Yosemite install problem looks fine.
> At first glance all looks fine! Could you try to install FixMacTeX2014.pkg found in /Applications/TeX and let us know if that helps.

Same situation after installing FixMacTeX2014.pkg, that is:
  - pdflatex and bibtex work from the TeXworks GUI and from the Terminal
  - LaTeXmk fails from the TeXworks GUI but succeeds from the Terminal

> Finally, what does
> which pdflatex
> return?

[~]$ which pdflatex

[~]$ ls -l /usr/texbin/pdflatex
lrwxr-xr-x 1 cabanac 6 Jun 18 23:14 /usr/texbin/pdflatex -> pdftex

[~]$ ls -l /usr/texbin/pdftex
-rwxr-xr-x 1 root 1896456 May 22 23:39 /usr/texbin/pdftex

[~]$ cd /usr/texbin

[texbin]$ pwd -P

(same result before and after installation of FixMacTeX2014.pkg)

I also tried to remove and install a fresh version of TeXworks, in vain.

Dear forum members: Does anybody run into the same trouble as me while compiling with LaTeXmk on TeXworks?

Thanks again for your time and efforts.


More information about the texworks mailing list