[texworks] xubuntu

Jean-Claude Raoult JC.Raoult at free.fr
Thu Jul 12 08:31:47 CEST 2012

Le 8 juil. 2012 à 17:30, Stefan Löffler a écrit :

> […] OK, so TeXworks is installed, but when opening files the system is
> looking in the wrong place.

Yes, it was certainly the case. I fixed it, or rather, it was fixed in some way,
after fiddling somewhat with the PATHS..
Now, when clicking on foo.tex, TeXworks does appear.

> […] Do you have
> 1) a TeX distro installed under Xubuntu?
> 2) the XeTeX package installed for it?
> 3) tried running xetex from the command line (with `xetex foo.tex`)?
> I suspect that 3) does not work, in which case the problem most likely
> lies in the configuration of the TeX distribution (which one do you use?
> TeXLive?)
> Stefan

You are right : 3) did not work, but TeXworks was not in fault there,
only the TeX distribution. I suppressed everything and re-downloaded it
from scratch. Nevertheless, there are still errors in the postinstallation
scripts: error 1 and error 127, depending on the dependency which is
not satisfied, I suppose.
  I tried successively to download trough the "logithèque Ubuntu" and again
through Synaptic. Same disease. I shall now try to download "by hand";
but I noticed that TeXlive scatters its children here and there on the file
system instead of putting its files in a single directory. So I reckon it will
be difficult.
  As William of Orange said, "Inutile d'espérer pour entreprendre, ni de
réussir pour persévérer."

Thank you for your hints,

				Jean-Claude Raoult

More information about the texworks mailing list