[texworks] TeXworks - Typeset and View PDF

Paul A Norman paul.a.norman at gmail.com
Mon Dec 5 00:05:46 CET 2011

Hi Milan,

As far as I know the .tex document needs to be actually open in TeXworks,
and the .pdf outputted has to be in the same directory as the open .tex
that you are typesetting for things just to flow and show.

AFAIK For these things TeXworks does not back read in your shell settings
on the Typeset tabs, those settings are generally only for passing out to
the shell/ comandline (--IYL) when TeXworks Typesets, and internally
TeXworks takes no more notice of them in determining what .pdf to open for
a document open in the editor.

So if your .pdf is being output to a different directory to the .tex that
you have open in TeXworks, you are not going to see it in the previewer
when that Typeset run is finished.
I have raised it here before, but could see that it was not a great issue
for others.

The same issue arrises when a colleagure may be viewing a .tex and ,odf
through a Local Area Network (even non drive substitutions), and can not
sync between the previewer and the ,tex document.

I am not sure from your description whether those command line switches you
are setting for passing to pdflatex are pointing to the .tex editor
document that is in focus in TeXworks when you issue the Typeset command in
TeXworks. As said, if not, you would not see the .pdf open in the previewer
when typesetting is finished.

Allowing that I am not sure exactly  what you are trying to achieve
... what you could do is run your pdflatex command from a shell aware of
your LaTeX distribution, or even do it from a Texworks Script, then open
the relevant .tex in TeXworks after pdflatex is completed (that would open
any .pdf associated with the .tex), you may be able to detect that in a
shell script or in a TeXworks Script result and open the .tex up in
TeXworks from there.

Otherwise generally if your .tex is open in TeXworks (and the document is
in good order), and you run pdflatex using TeXworks Typeset command, you
should see the finished product. If that is not happening in a
straightforward scenario, then perhaps use Menu> File / Remove Aux Files,
and rebuild any  indexes biblios etc again on successive runs and your ,pdf
should be showing.


On 5 December 2011 03:04, Milan Jaroš <milan.jaros at gmail.com> wrote:

>  Hello,
> I tried to configure TeXworks (see attachment) to be able Typeset some
> specific file from any file used by \input but I failed. I tried to Google
> out something but without success. :(
> File is typeset fine but preview on right side is not working even if I
> have "View PDF after running" checked. If I use default pdfLaTeX it is OK
> but it does not work with my configuration (see attachment). Please, can
> you see what have I done wrong? Thank you for your time.
> Best regards,
> Milan
> ----- configuration info -----
> TeXworks version : 0.4.3r857 (MiKTeX 2.9 64-bit)
> Install location : C:/Program Files/MiKTeX
> 2.9/miktex/bin/x64/miktex-texworks.exe
> Library path     : C:/Users/DZCMJ1E/AppData/Local/MiKTeX/2.9/TeXworks/0.4\
> pdfTeX location  : C:/Program Files/MiKTeX 2.9/miktex/bin/x64/pdftex.exe
> Operating system : Windows Microsoft Windows 7 Ultimate Edition, 64-bit
> Service Pack 1 (build 7601)
> Qt4 version      : 4.7.2 (build) / 4.7.2 (runtime)
> ------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/texworks/attachments/20111205/3febc483/attachment.html>

More information about the texworks mailing list