[texworks] Texworks quit working (on windows)

Paul A Norman paul.a.norman at gmail.com
Sun Oct 2 03:40:07 CEST 2011

Ok lets walk this through exhaustively so we can absolutely and
consistently rule out certain matters.

Please try setting your path in the previously described  dos shell to

set path=

It will probably then report as



Then try again to rerun texworks.exe

We need to absolutely rule out all possible dll contamination. I just
tried such a path statement and it worked for TeXworks to launch.

I have known of portable python type applications where an alpha or
beta or poorly designed application has actually, without warning,
copied dlls around the place for the developer's convenience or

The forward slashes in the ini should not be a problem at all. {They
are however sometimes in TeXworks scripting (under Windows Xp at
least) when using system(), sometimes there, if the rest are / the
last has to be a \ especially for certain os dos commands to be

If this does not help us, we'll use the Windows built in tools first
in the real machine, to monitor what is happening.

The first one is to check that your Virus software hasn't decided to
list texworks.exe as an unfriendly, if that has happened often the
virus checker will just quietly disable it from running whenever an
attempt is made, and possibly with no further visual information.

Check for any system security settings as well.  Windows automatic
updates have been known to passively alter things as well.

Then please open up your system monitor, on Xp I would go crtl Alt Del once.
And again watch processes, not applications. I realise from reading
the transcript here that you may have done some of this already.

First click on Image Name, and get them in alphabetical order.

TeXworks is a "start once" application, but what we want to check that
there is no other process (from all the installing and un-installing)
somehow partially starting TeXworks at start-up as that also will stop
you directly starting TeXworks directly. I know this will not seem
likely or perhaps even  rational (but I have seen such things) so lets
rule it out.

Scan the list under Image name, and see if any form of TeXworks ( or
TeXworks starter form TeXLive) is already launched.

Assuming nothing was found there.. (if it was, select it, and End
Process on it, and try to launch TeXworks in your dos prompt)

Now Click on CPU column header and make things using the most CPU
appear at the top.

Prime your dos prompt with TeXworks.exe to go,
then dexterously hit enter in your dos prompt to start TeXworks.exe
while carefully gazing intently at your process CPU column and see
what kicks in just before, and after TeXworks flashes past.

If this does not help, we may have to look at installing some process
monitoring tools, and others on the list may be able to chime in here

(I don't want to unduly trouble you, but if you do have a virtual box
with an Xp or other windows install running in it, please try a
freshly downloaded TeXworks portable install there, confirm it runs,
then try copying your TeXworks portable install from the real machine,
into the virtual box, and trying the copied version again in the
virtual box.)

And of course consider running  Malwarebytes or similar if you have
not done so already.


On 2 October 2011 13:26, K. Frank <kfrank29.c at gmail.com> wrote:
> Hi Paul!
> Thanks for your suggestions.
> On Sat, Oct 1, 2011 at 6:42 PM, Paul A Norman <paul.a.norman at gmail.com> wrote:
>> HI,
>> If you have not already fully tried this set of steps here (and I
>> could not tell from the transcript here) please try building on
>> Jonathan and Stefan's and others' points, but for diagnostic reasons
>> to firmly rule one set of possible circumstances out, do something
>> that should not now  be at all necessary otherwise.
>> But as there is still at least one possible external dll known to be
>> being looked for (Python), for diagnostic purposes, start a cmd shell
>> (dos prompt) type path, there you will see your whole combined local
>> user and system set path.
> This is interesting.  Between when TeXworks worked for me and when
> it stopped working I did install an application that uses python and
> came bundled with some python dll's.
> However, this "installation" only involved unzipping an archive, did not
> add anything to my path, and was carried out on a removable drive that
> is not currently connected to the computer in question.
> So the python connection is most likely a red herring.
>> As once initialised, a cmd shell effectively maintains its own path
>> statement in isolation, write what you would consider to be the most
>> minimal path statement necessary under your version of windows. For
>> example on my system I would type:
>> set path = c:\windows;c:\windows\system32
> Okay, I did this.
>> Remember you are only setting the path for the current cmd shell, not
>> the whole system. If you are not sure about that, be logged in as
>> something less than an administrator.
>> Now try from that dos shell (with the adjusted path statement) try to
>> start the portable version of TeXworks that you installed separate
>> from TeXlive.
> I cd'ed into the (non-Tex Live) directory that contains TeXworks.exe,
> and tried to run "TeXworks.exe".  No go.
>> Check first, for these unusual circumstances, that your
>> TW_conf directory is perhaps a full path, with a drive letter, in your
>> TeXworks texworks-setup.ini that you adjusted. (Otherwise you can use
>> a path starting \ on windows for TeXworks portable normally).
> The contents of my texworks-setup.ini file is:
>   inipath=C:/Users/<me>/TW_conf/
>   libpath=C:/Users/<me>/TW_conf/
> Note, per the TeXworks manual, I use forward slashes ('/'), rather than
> backslashes ('\').  The directory does exist, it is empty, and it remains
> empty after attempting to launch TeXworks.
>> If TeXworks does now start, that would suggest (after all that you
>> have tried) in the first instance that after all some dll is probably
>> the issue for some reason, and a same named older python library is
>> possibly the most likely candidate.
> (Well, TeXworks didn't start.)
>> It would be somewhere in that initial  path statement that you changed
>> away from, and may be from something else you installed or tried out
>> in-between TeXworks working, and then not working, and the main
>> programme may not even still be installed.
>> If that does not help, we will have to look at more subtle things, and
>> perhaps even consider other unwated possibilities.
> Yes, if you have other possible causes in mind, please let me know.
>> paul
>> P.S I should have added, that for completeness if TexWorks still does
>> not start check the directories that you left in the minimal path
>> statements for the python dll
> There is no python dll in my minimal path:
>   dir %PATH% | find /I "pyth"
> returns nothing.
>> or any other historically used TeXworks dll.
> Aye, there's the rub.  I don't know what the other "historically used
> TeXworks dll[s]" are.  If there are other likely candidate dll's, I could
> certainly look for them.
> I appreciate your help.  Any further suggestions would be very welcome.
> Thanks.
> K. Frank
>> On 2 October 2011 03:34, K. Frank <kfrank29.c at gmail.com> wrote:
>>> Hello All!
>>> Wow!  Nothing works.
>>> I have tried a lot of the suggestions given above.  (The only thing
>>> I haven't tried is reinstalling TeX Live again from scratch, because
>>> doing so is Not Fast (TM).)
>>> ...

More information about the texworks mailing list