[texworks] Texworks quit working (on windows)

Paul A Norman paul.a.norman at gmail.com
Sun Oct 2 00:42:31 CEST 2011


If you have not already fully tried this set of steps here (and I
could not tell from the transcript here) please try building on
Jonathan and Stefan's and others' points, but for diagnostic reasons
to firmly rule one set of possible circumstances out, do something
that should not now  be at all necessary otherwise.

But as there is still at least one possible external dll known to be
being looked for (Python), for diagnostic purposes, start a cmd shell
(dos prompt) type path, there you will see your whole combined local
user and system set path.

As once initialised, a cmd shell effectively maintains its own path
statement in isolation, write what you would consider to be the most
minimal path statement necessary under your version of windows. For
example on my system I would type:

set path = c:\windows;c:\windows\system32

Remember you are only setting the path for the current cmd shell, not
the whole system. If you are not sure about that, be logged in as
something less than an administrator.

Now try from that dos shell (with the adjusted path statement) try to
start the portable version of TeXworks that you installed separate
from TeXlive. Check first, for these unusual circumstances, that your
TW_conf directory is perhaps a full path, with a drive letter, in your
TeXworks texworks-setup.ini that you adjusted. (Otherwise you can use
a path starting \ on windows for TeXworks portable normally).

If TeXworks does now start, that would suggest (after all that you
have tried) in the first instance that after all some dll is probably
the issue for some reason, and a same named older python library is
possibly the most likely candidate.

It would be somewhere in that initial  path statement that you changed
away from, and may be from something else you installed or tried out
in-between TeXworks working, and then not working, and the main
programme may not even still be installed.

If that does not help, we will have to look at more subtle things, and
perhaps even consider other unwated possibilities.


On 2 October 2011 03:34, K. Frank <kfrank29.c at gmail.com> wrote:
> Hello All!
> Wow!  Nothing works.
> I have tried a lot of the suggestions given above.  (The only thing
> I haven't tried is reinstalling TeX Live again from scratch, because
> doing so is Not Fast (TM).)
> Summary:
> My initial situation:
> I had installed TeXworks and TeX Live, and it was working, but then it
> quit working.
> I uninstalled both TeXworks and TeX Live, and I reinstalled TeX Live
> from scratch.  I still couldn't get TeXworks (now the version that
> came bundled with TeX Live) to work.  This is where I left off.
> I tried running TeXworks again, just to check -- failed.
> I ran:
>   tlmgr install --reinstall texworks
> tlmgr asked that it be updated itself, so I ran:
>   tlmgr update --self
> and ran:
>   tlmgr install --reinstall texworks
> This all seemed to work.
> I tried running TeXworks (the TeX Live version) -- failed.
> I installed the separately packaged version of TeXworks.  This seemed to
> work, except at the end when the installation wizard shows the "Finished"
> but with a check box to "Launch TeXworks", I checked the check box, and
> got the following pop-up message:
>   Setup
>      Unable to execute file:
>      C:\Program Files (x86)\TeXworks\TeXworks.exe
>      CreateProcess failed; code 740.
>      The requested operation requires elevation.
> and TeXworks didn't start.
> I tired running TeXworks from the (newly created TeXworks start-menu
> entry.  It brought up the UAC "make changes" dialog, and I clicked yes.
> TeXworks didn't start.
> I tried running the start-menu entry again, but used "Run as administrator".
> Failed.
> I uninstalled the separately packaged version of TeXworks.
> Per Stefan Löffler, I did the following...
> On Thu, Sep 29, 2011 at 7:27 AM, Stefan Löffler <st.loeffler at gmail.com> wrote:
>> Hi,
>> sorry to chime in so late, but I have been quite busy recently.
>> Anyway, the latest "official" TeXworks binaries for windows (i.e. those
>> distributed via Google Code, not via any TeX distro) should not depend on
>> any dlls - everything should be linked in (except for Python).
>> So, my suggestion would be to download TeXworks
>> (http://texworks.googlecode.com/files/TeXworks-w32-0.5-r932.zip),
> Okay, I did that.
>> extract it (e.g., on your desktop)
> Did that.
>> and run it
> I tried running it (clicking on the TeXworks.exe file in "Windows Explorer"
> and typing "start TeXworks.exe" in a command prompt.  This failed.
>> in portable mode (see the TeXworks
>> manual, section 5.7 for how to do that;
>> http://texworks.googlecode.com/files/TeXworks-manual-r814.pdf).
> I created the texworks-setup.ini file (in the same directory as
> TeXworks.exe, per (as I understand it) the manual.  I then tried
> again to run TeXworks.exe.  This again failed.
>> This way,
>> you can ensure that it is completely independent, doesn't depend on a TeX
>> distro, and doesn't use any resources other versions might (have) use(d)
>> (e.g., registry keys, configuration files, etc.). Also, by using the
>> "official" version, you get around all the issues arising from wrappers in
>> other directories etc.
>> If that still doesn't work, see if in the libpath (see manual) you get
>> several files and subdirectories, and in the inipath (again see manual) a
>> configuration file.
> I don't see any files or subdirectories in the libpath.  That is, I created
> a TW_conf directory, and listed it for both the inipath and libpath in the
> texworks-setup.ini file.  This directory has nothing in it (even after
> attempting
> to launch TeXworks.
>> HTH,
> Sorry, it didn't help, at least not yet.
>> Stefan
> Basically, I find myself in a situation where nothing works.  Under normal
> circumstances, I would write off TeXworks as non-functional, at least on
> windows.  But the crazy thing is,it used to work, more or less out of the
> box.  I'm certainly not an expert, and I don't know what all the tricks and
> features are, but as far as I could tell, TeXworks was fully functional.
> But then it mysteriously quit working, and no manner of uninstall / reinstall
> has been able to fix it.
> Any further suggestions would be most welcome.
> K. Frank

More information about the texworks mailing list