[texworks] Texworks quit working (on windows)

Jonathan Kew jfkthame at googlemail.com
Wed Sep 28 19:09:00 CEST 2011

On 28 Sep 2011, at 17:47, K. Frank wrote:

> Hi Alain!
> On Wed, Sep 28, 2011 at 9:09 AM, Alain Delmotte <esperanto at swing.be> wrote:
>> Hi!
>> Le 28/09/2011 10:57, Lars Madsen a écrit :
>>> ...
>>> Have you ckecked that there are not any corrupt TeXworks
>>> configuration files.
>> If it is the Tex Live version of teXworks, go to
>> c:\users\<you>\.texlive2010\texmf-config and suppress the "texworks" folder.
>> So you suppress all the configuration files.
>> Restart TeXworks from Tex Live, a new folder will be created.
> I have a "texworks" folder, but it is empty:
>   C:\Users\<me>\.texlive2011\texmf-config\texworks
> I renamed it and restarted TeXworks.  The empty texworks folder was
> recreated, and I have the same problem -- the TeXworks process exits
> almost immediately.

I haven't followed this thread in detail, so I apologise if I'm repeating things that have already been suggested.... it sounds to me as though you might have incompatible versions of some library (DLL) that texworks uses. I'm not sure how many DLLs the current Windows builds depend on, but if you have a mixture where you're trying to launch an .exe from one release (miktex? tl2010? tw standalone?) but it is finding DLLs that came with a different release (somewhere in your Windows PATH?) there'd be a very high likelihood of failure.

Normally, I'd expect all the necessary DLLs to be installed in the same folder as the .exe itself, so that the right ones are found, but if that's not the case on your system then it'll search for them in the current PATH, and may find the wrong one.

An alternative theory: some kind of permissions issue that's preventing TW from accessing a file it needs. Does it make any difference if you right-click TW and ask it to "Run as Administrator"? (I think that's the Win7 way - not at a Windows machine right now.)


>> But I am using Tex Live 2010.
> For what it's worth, I am using TeX Live 2011.
>> There are 2 TeXworks.exe: one in c:\texlive\2010\win32\bin and one with
>> companion folders in c:\texlive\2010\tlpkg\texworks.
>> The files have not the same date but are the same version of TeXworks.
> Yes, I also have two copies of texworks.exe.  The one that Akira identifies
> as the wrapper program is much smaller, and is the one I run (from the
> "TeX Live 2011 / TeXworks Editor" shortcut that the TeX Live installation
> process added to my start menu).  Just for fun, I ran the "real" texworks
> directly, and it exited almost immediately.
> I do not know how to tell which texworks.exe is showing up briefly in
> the windows task manager when I launch TeXworks.  Perhaps the
> wrapper, perhaps the "real" texworks, perhaps both (but I never see
> both at the same time).
>> As far as I can remember, I installed TeXworks before Tex Live (I was using
>> MikTeX before, but shifted because of the difficulties knowing if you are
>> user or administrator).
>> The TeXworks, not from Tex Live, was updated regularly and is now
>> 0.5r.932(official)
>> The configuration files for this TeXworks are in c:\users\Alain\texworks.
>> I am under Windows 7(64) but Tex Live is win32.
>> Hope this helps,
> Well, it helps, in that you have TeXworks / TeX Live working under windows
> (and 64-bit windows 7, in fact), but I still don't know what I should do.
> Maybe it's a coincidence, but when I had TeXworks working, I had first
> installed just TeXworks from a TeXworks installation package, and then
> I installed TeX Live.  It sounds like you had first installed TeXworks via
> MiKTeX, and then installed TeX Live.  (But it looks like you are running
> TeXworks from your TeX Live installation, so maybe this is a red herring.)
>> Alain
>>> Is it possible to start it from the commandline instead of
>>> clicking on it (it might leave some messages before
>>> disapearing)
> To answer Lars's question, when I start texworks.exe from the command
> line, it still exits almost immediately, but prints out nothing -- no messages
> or error information.
> I've tried starting both the wrapper and real texworks from the command
> with the same result of nothing.
> I am thinking of trying three things.  Both involve reinstalling TeX Live,
> which makes experimentation somewhat difficult, because TeX Live, to
> say the least, is not a fast installation process.
> First, uninstall everything to make sure I get a clean install.
> Then:
> 1)  Try to install TeX Live 2010, because that's what people seem to have
> working on windows.  But I'm not really sure how to do this, because my
> understanding is that the installer just goes and gets whatever is current on
> the mirror it chooses.  So I would think that I would get the latest TeX Live
> 2011, and I don't know how to tell the installer to do otherwise.
> 2)  Install TeXworks first from the TeXworks installation package that I
> downloaded.  Then install TeX Live.  The motivation is that this is what
> I think I did originally when TeXworks worked for a while.  (But even if
> this were to work, it still wouldn't explain why TeXworks quit working.)
> 3)  Install MiKTeX.  The hope would be that because MiKTeX is not the
> same package as TeX Live, maybe it would work differently / better (and
> because, as I understand it, some people do have it working on windows).
> Any thoughts on which plan I should try first?  Which might be easiest,
> and most likely to succeed?
> Ideally, I would like to understand the root cause of the problem and fix
> it, rather than just trying random variations on the reinstallation theme.
> That TeX Live installation process, is, to say the least, not fast...
> Again, thank you for all of your help, and for any further thoughts you
> may have.
> K. Frank

More information about the texworks mailing list