[texworks] Scripting-related hangs & crashes (was: We've reached r700+; please test)

Paul A Norman paul.a.norman at gmail.com
Mon Dec 6 00:46:28 CET 2010

Ok, I've had problems for a while with Script Reload, and put an
issue, or a note to an existing Issue, up some time ago.

I started to wonder if it had anything to do with conflicting Alt key
combinations in scripts, and some problem for reload in resolving
these that does not happen on Tw start-up for some reason, so I put an
Issue up about that as well I think.

If I do a Script reload, even just after opening an existing Tw
document (even though no scripts have been changed or added) and then
when focus is back (ten to twelve seconds)  immediately run a simple
Alt key script combination (one that normally works well) Tw crashes,
no error message just this ...


So again  - when I start Tw and open a recent document and use script
shortcuts - no problem.

If I reload scripts and then immediately once it comes back (ten to
twelve seconds), try to  use an Alt key Script combination - Tw

If I rename script folder and reload Scripts, a new script folder
appears (as expected) and is populated by the default scripts.
If I then immeadiately try a script Alt key combination - well a
search shows that there aren't any Alt key combos to try in that
directory - so unless I modify a default script I can not test that.

Restore original scripts directory, reload scripts, try alt key combo, Tw crash.

With restored scripts directory, reload scripts, do something else
first - like make and save a new document, then try alt key combo - no
crash! And expected script runs well.

I have been running in portable mode for over a year now.


defaultbinpaths = ../../../LatexUtils/MiTeX 2.8.3541 Portabe/miktex/bin
inipath = ./config
libpath = ./config

And TeXworks/config/TUG/eXworks.ini

note: I have various of Tw's dlls and its stuff in the exe directory

So I copied my config (with scripts etc) directory to a new clean
directory, and unpacked the latest TeXworks-w32-v0.3r712-build1.zip
(four hours old) into there as well.

My structure was then ...

texworks-help (dir)
config (dir)
poppler-data (dir)
Lib (dir)

Started Tw, saved the new document, immediately reloaded scripts,
tried to use a normal Alt key combo, Tw crashed.

Restarted Tw, saved the new document, did NOT reload scripts,
immediately tried to use the same Alt key script combo, script worked
well, Tw did NOT crash.

Hope this helps narrow it down a bit.


On 5 December 2010 22:25, Stefan Löffler <st.loeffler at gmail.com> wrote:
>  * Get rid of the old versions of Tw. You could move them to a USB stick
> or something. Ideally, this shouldn't change anything, but you never
> know where Windows meddles
>  * Run Tw in full portable mode (ini+lib). This avoids writing to the
> registry (it uses the ini file instead), and it allows to...
>  * Remove all scripts (from the lib/scripts folder in portable mode).
> This should avoid problems that may be caused by reloading the script
> list (if any).

On 5 December 2010 22:36, Stefan Löffler <st.loeffler at gmail.com> wrote:
> One more thing: what are the actual error messages when Tw crashes?
> I.e., what's displayed in the dialog that pops up (error code,
> description, etc.)?
> -Stefan

More information about the texworks mailing list