[texworks] external read-access causes TeXWorks to revert open file to old version

Stefan Müller warrence.stm at gmx.de
Thu Nov 25 22:47:57 CET 2010

Sorry, there was something missing in my last mail.

There were the following debug messages:

Loading: "/home/user/test_old.tex" 
Loading: "/home/user/test.tex" 
Changed: "/home/user/test.tex" 
QDateTime("Do. Nov 25 22:31:05 2010") 
Loading: "/home/user/test.tex" 
QTextCursor::setPosition: Position '61889' out of range
Changed: "/home/user/test.tex" 
QDateTime("Do. Nov 25 22:30:34 2010") 
Loading: "/home/user/test.tex" 

[Last line: "Segmentation fault" IIRC]

It seems like a random crash, but as I mentioned somewhere in this thread, in 
some cases TW crashed instead of showing me an old version of the file.

Thanks again,

Am Donnerstag 25 November 2010, 22:40:49 schrieb Stefan Müller:
> Hi,
> sorry, but I couldn't try your patch until now. I did a quick test which
> worked out well. I will do some more testing in the not to far future (I
> hope) and report back on this.
> One additional note: When I first tried a dummy commit today TW crashed, I
> got the following on the command line:
> Thanks alot!
> Stefan
> Am Dienstag 02 November 2010, 20:05:10 schrieb Stefan Löffler:
> > Hi,
> > 
> > my last patch (probably) had an error. Please use the version attached
> > here instead.
> > 
> > HTH
> > Stefan

More information about the texworks mailing list