[texworks] Buggy character checking in proxy authentication dialog (doesn't allow a dot) (fwd)

Marko Käning mk362 at mch.osram.de
Thu Oct 14 18:50:11 CEST 2010

Dear MiKTeX developers,

I stumbled over this already a while ago with version 2.8, now I again 
trip over the following bug:

  It is impossible to enter a dot ('.' character) as part of the username 
  when entering the user information in the proxy authentication dialog.

I was surprised that the inital download using the setup wizard worked 
fine, but when it came to downloading new packages from the internet from 
within TeXworks I ran into the problem described above which already 
stopped me with version 1.8. :(

It's very odd and unnecessary that the '.' character is explicitely 
forbidden for the user name. It would be great if there was a fix for 

Best regards,

----- configuration info -----
TeXworks version : 0.3r670 (MiKTeX 2.9)
Install location : C:/Program Files/MiKTeX 
Library path     : C:\Documents and Settings\m.kaening\Local 
Settings\Application Data\MiKTeX\2.9\TeXworks\
pdfTeX location  : C:/Program Files/MiKTeX 2.9/miktex/bin/pdftex.exe
Operating system : Windows Microsoft Windows XP Professional Service Pack 
3 (build 2600)
Qt4 version      : 4.7.0 (build) / 4.7.0 (runtime)

More information about the texworks mailing list