[texworks] 'No SyncTex data available', Xunbuntu 9.10, TeXWorks 0.3 ver 571

Paul A Norman paul.a.norman at gmail.com
Sun Apr 4 12:52:37 CEST 2010

Thanks Jonathan and Alain,

>From your questions Jonathan, I had a look at my tex distribution and
realised that it was only TexLive 2007 (it came with Ubuntu 9.10).

Set up for an update using this repository:

sudo add-apt-repository ppa:aelmahmoudy/tl2009

Got TeXLive2007 off, and did the TeXLive 2009-07 install (not having
any reference to a more recent one not having seen Alain's message

sudo apt-get install texlive

Once completed then did a full install using synaptic texlive-full
package installation.

Now scyntex works fine both between source and preview and, preview and source.

My TeXWorks is:
  2007-2010 Jonathan Kew & Stefan Löffler Version 0.3 (r.571),
  with the svn offset on the version number that Alain has also noticed.

So I take it that we should avoid the latest TeXLive (April? 2010) for now?


On 4 April 2010 20:16, Alain Delmotte <esperanto at swing.be> wrote:
> Hi!
> Lars Madsen a écrit :
>> Paul A Norman wrote:
>>> I'm currently setting up an Xunbuntu 9.10 box, using TeXWorks 0.3 ver
>>> 571 installed after adding ppa:texworks/ppa. (0.3.0~svn581~karmic1
>>> Stefan Löffler  (2010-04-02) )
>>> This document trial was done using the built in template for article
>>> with small safe modifications.
>>> When the typesetting has finished the document correctly shows in the
>>> preview pane and a message briefly appears in the preview frame's
>>> footer panel saying that there is 'No SyncTex data available', and so
>>> of course none of the 'Jump to ..' work
>>> Do I need to install something else or ...?
>>> Paul
>> check the path to your document. The sunctex feature does not seem to like
>> non ascii chars in the path.
>> For example if I add the danish letter ø (which is non ascii) to the path
>> to the file. Synctex fails.
> I have the same problem under Ubuntu9.10
> I use the latest TeXlive (installed from the web on Thursday.
> There is no non-ascii letters (not even space) in the path.
> TeXworks is the same 0.3 r571 (shouldn't it be 581!!) compiled by Stefan on
> the 02/04 and put at launchpad
> Alain
>> This is a known issue.
>> /daleif

More information about the texworks mailing list