[texworks] compilation of TWPythonPlugin.cpp failed

Atsuhito Kohda kohda at pm.tokushima-u.ac.jp
Mon Feb 22 01:08:45 CET 2010

Hi all,

On an amd64 machine (Debian/sid), if I try to compile TWPythonPlugin
it fails as follows:

| g++ -c -pipe -fno-strict-aliasing -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I../../src -I/usr/include/python2.6 -Imoc -o obj/TWPythonPlugin.o TWPythonPlugin.cpp
| TWPythonPlugin.cpp:317: warning: unused parameter 'kw'
| TWPythonPlugin.cpp: In static member function 'static QVariant PythonScript::PythonToVariant(PyObject*)':
| TWPythonPlugin.cpp:458: error: cannot convert 'int*' to 'Py_ssize_t*' for argument '2' to 'int PyDict_Next(PyObject*, Py_ssize_t*, PyObject**, PyObject**)'
| make[1]: *** [obj/TWPythonPlugin.o] Error 1

It works fine on 32-bits machines but seems to fail on 64-bits
machines.  I use TW svn569 version.

Is it possible to compile TWPythonPlugin on a 64-bits machine?

Thanks in advance.
Best regards,			2010-2-22(Mon)

 Debian Developer - much more I18N of Debian
 Atsuhito Kohda <kohda AT debian.org>
 Department of Math., Univ. of Tokushima

More information about the texworks mailing list