[texworks] TeXworks and Ubuntu 8.10

Greg Bennett gwbennett at sentex.ca
Fri Sep 18 02:27:00 CEST 2009

 Edad! I followed the steps on 
under Ubuntu (Hardy) & Debian ..
and at ./texworks, up popped the application. Much experimenting lies 
ahead now.
I have used MikTeX + WinEdt very happily fro many years under MS, so I have
high expectations.

I still don't understand why the attempts to install the three packages 
below failed. I note the
the code.google instructions require me do download/install 
libpoppler-qt4-dev and
libhunspell-dev so perhaps the necessary things have been built from these.

Cheers /Greg Bennett
Greg Bennett wrote:
> Stefan, I am running Intrepid rather than Hardy.
> When I try
> sudo apt-get install libhunspell-1.1-0 libpoppler-qt4-2 libpoppler2
> I see Reading Package list... Done
>        Building dependency tree
>        Reading state information... Done
> Package libhunspell-1.1-0 (or the others) is not available, but us 
> referred to by another package.
> This may mean that the package is missing, has been obsoleted, or is 
> only available from another source
> E: Package libhunspell-1.1-0 (or the others0 has no release candidate.
> Poking about on Ubuntu leaves me with locations on some *Hardy* 
> archives and a suggestion that I
> add lines pointing to these to sources.list; I tried but to no effect.
> I do see libhunspell-1.2 and libpoppler-qt3 about, but I assume that 
> the build script for TeXworks is version
> specific.
> I suppose I have to wait until Intrepid stuff becomes available. I am 
> told I can download the packages I'm missing
> but I am then unsure how to install them in the proper places and I'm 
> not sure I am confident enough to try to
> build TeXworks from the ground up.
> Thx again for your help
> /Greg
> **
> Stefan Löffler wrote:
>> Hi Greg,
>> On 2009-09-16 22:27, Greg Bennett wrote:
>>> The following packages have unmet dependencies:
>>>  texworks: Depends: libhunspell-1.1-0 (>= 1.1.6-1) but is not 
>>> installable
>>>                  Depends: libpoppler-qt4-2 (>= 0.6) but is not
>>> installable
>>>                  Depends: libpoppler2 (>=0.0) but is not installable
>>> I was wondering whether I have broken something, or whether I have
>>> failed to take precautions
>>> before invoking the attempt to install TexWorks.
>> This is strange. Tw does depend on these packages on Hardy, however
>> according to http://packages.ubuntu.com/hardy/allpackages (warning,
>> *long* list) they should be present in the standard Ubuntu repositories.
>> What does
>>     sudo apt-get install libhunspell-1.1-0 libpoppler-qt4-2 libpoppler2
>> say? Which package sources do you have selected (e.g. main, universe,
>> ..., hardy-security, hardy-updates, ...)?
>> In the worst case, you could probably still download the packages from
>> the website I mentioned above. But that's not how it should work (it
>> should be as simple as I described previously ;)).
>> HTH
>> Stefan

More information about the texworks mailing list