[texworks] Linguist problems (was: translation updates)

Mojca Miklavec mojca.miklavec.lists at gmail.com
Tue Jul 7 19:19:16 CEST 2009

On Tue, Jul 7, 2009 at 17:44, Stefan Löffler wrote:
> Mojca Miklavec schrieb:
>>>>>> One oddity. I have just figured out (for a little while) that the
>>>>>> window in upper right corner actually displays translations in
>>>>>> graphical mode. I saw this behaviour for just about a few minutes. Now
>>>>>> it says
>>>>>>    File /Users/mojca/dev/tex/texworks/trans not readable
>>>>>> again. Did anyone else experience a similar behaviour?
>>> Did you try running lupdate to refresh the translation files?
>> Yes. Several times. (Maybe my lupdate is misfunctioning?)
> I'm beginning to suspect the same...
> No, I don't see the translated GUI that should be displayed. I checked
> the .ts file and found that it doesn't contain any references to the
> source files from where the strings are taken (which it should - see the
> german file for comparison).
> Strangely, running lupdate doesn't have any effect. If I delete all the
> files, however, and then run lupdate I get all the correct location lines.
> I've written a small script to merge the translations you've already
> done with that new file. So try:
> 1) remove all files in the trans/ folder in your texworks directory
> 2) copy the file attached to this mail into that folder
> 3) run lupdate as usual

Great. This works, but ... running lupdate again apparently destroys
the file. I wish I knew where lupdate came from. I have
    /opt/local/bin/lupdate --version (this one comes from MacPorts)
    > lupdate version 3.3.8
    /usr/bin/lupdate-4.5 --version
    > lupdate version 4.5.1
I used the second one to generate the file, but I have no idea how I
installed it (or what I should do in order to install the right
version on Mac).

I have figured out that I have yet another binary on the system that's
also 4.5.1. Can someone explain me:
- why it tries to update *all* files
- whether I should be worried about the warning message

/Developer/Tools/Qt/lupdate TeXworks.pro -ts trans/TeXworks_sl.ts
/Users/mojca/dev/tex/texworks/TeXworks.pro(38):Project MESSAGE: Unable
to determine TeX path, guessing defaults
Updating 'trans/TeXworks_ar.ts'...

    Found 402 source text(s) (0 new and 402 already existing)

Updating 'trans/TeXworks_de.ts'...

    Found 402 source text(s) (0 new and 402 already existing)

Updating 'trans/TeXworks_fr.ts'...

But that one apparently destroys the file as well. Any Mac-ish help from anyone?


More information about the texworks mailing list