[texworks] translation updates

Bruno Voisin bvoisin at me.com
Tue Jul 7 15:21:11 CEST 2009

Le 7 juil. 09 à 15:01, Mojca Miklavec a écrit :

> On Tue, Jul 7, 2009 at 14:44, Wolfgang Schuster wrote:
>> Am 07.07.2009 um 11:38 schrieb Mojca Miklavec:
>>> So if anyone could share a recent Mac binary with me or on google  
>>> code
>>> page, I would be grateful for that.
>> http://Wolfgang.Schuster.googlepages.com/texworks
> Thanks a lot ... but the application crashes before it starts.
> The log says:
> Dyld Error Message:
>  Library not loaded: /usr/local/lib/libpoppler-qt4.3.dylib
>  Referenced from: /Applications/TeX/TeXworks.app/Contents/MacOS/ 
> TeXworks
>  Reason: Incompatible library version: TeXworks requires version
> 5.0.0 or later, but libpoppler-qt4.3.dylib provides version 4.0.0
> I don't understand ... I have /opt/local/lib/libpoppler.5.dylib and
> /usr/lib/libpoppler-qt4.3.dylib, but the message above seems
> conflicting (I don't understand whether the library is actually too
> new or too old).

Same experience here (except that I don't have libpoppler.5.dylib,  
only libpoppler-qt4.3.dylib). Using the Qt 4.5 frameworks from the Qt  
site in place of the 4.3 frameworks provided by Jonathan doesn't help,  
it really seems to be too old dylibs.

As it happens, I was just working on a paper with TeXworks (r238) and  
missing things (printing, automatic creation of a menu for jumping to  
sections subsections etc. in the editor, page rotation in the viewer,  
continuous scrolling in the viewer) which I imagine are partly  
available in more recent builds.

Bruno Voisin

More information about the texworks mailing list