[texworks] translation updates

Mojca Miklavec mojca.miklavec.lists at gmail.com
Tue Jul 7 14:26:42 CEST 2009

On Tue, Jul 7, 2009 at 13:48, Stefan Löffler wrote:
> Hi,
> Mojca Miklavec schrieb:
>> May I ask for explanation of "Wrap around"...
> Wrap around in the context of find/replace means that the program should
> continue the search at the beginning of the document when it got to the end.

Hmmm ... quite possible that my version of TW is too old. I actually
figured out that I don't see that string anywhere and searching from
the end of document doesn't work either.

>> ...and the exact meaning of
>> "PDF file "%1" is locked; this is not currently supported."?
> There are several features in pdf files that are currently not
> supported. IIRC this line indicates that you would need a password to
> open the document but TW doesn't provide you with a mechanism to enter it.

I thought it meant that Acrobat has locked the file for writing. So
the string means "The action that you are trying to perform doesn't
work because PDF file is locked?" (When would PDF be locked when
processed with TeX? Or could one simply open any PDF document and the
message would only come up in that particular case?)

>> Also, what exactly does "balance delimiters" do?
> >From short experimentation, I found that it selects the text from the
> last opening to the next closing delimeter (e.g. parenthesis "()", "[]",
> "{}"), provided they match.

I see them highlighted anyway. And if I press that, nothing happens.

>> One oddity. I have just figured out (for a little while) that the
>> window in upper right corner actually displays translations in
>> graphical mode. I saw this behaviour for just about a few minutes. Now
>> it says
>>    File /Users/mojca/dev/tex/texworks/trans not readable
>> again. Did anyone else experience a similar behaviour?
> I can't remember such an experience, but which application are you
> talking about? Qt Linguist? Have you
> 1) updated the sources
> 2) moved the folder (ok, unlikely, but stranger things are known to have
> happened ;))
> 3) tried restarting the app

I have tried all of these, but nothing helps.

Wait ... there's actually only one way to get it working. If I first
open German translation as read-only and the Slovenian translation
after that, it starts working (I mean: I see German menus in that
window). Open recent won't work. If I only load Slovenian translation
it won't work either.


More information about the texworks mailing list