[texworks] Custom shortcuts are not working

Stefan Löffler st.loeffler at gmail.com
Thu Jun 11 17:31:57 CEST 2009

Hi again,

I finally booted into my Windows partition again and tried out all the
things that recently caused problems. I'm happy to announce that I found
solutions ;).

On 2009-06-09 11:06, Alain Delmotte wrote:
> Stefan Löffler a écrit :
>>  * Could you do the following:
>>    Create a file C:\actions-test.ini containing the one line
>>    actionOpen = Ctrl+1
>>    Then edit your TeXworks.conf and put the following line
>>    shortcutsMapFile=C:/actions-test.ini
>>    right under the line
>>    [General]
>>    (and make sure there's no other line starting with shortcutsMapFile)
>>    Then save the file, run TW, and press Ctrl 1, which should bring up
>> the open dialog. If it doesn't we need to get into more debugging.
> Done!
> Doesn't work.
> My actions.ini is now:
> actionOpen = Ctrl+1
> actionAbout_TW = Alt+,
> actionBalance_Delimiters = F9
> but none works and I tried with only the first line.

Should finally be fixed by the new patch I just posted on google code
(http://code.google.com/p/texworks/issues/detail?id=17#c11). The problem
was that parts of old code were used that only looked in the registry
for configuration options and hence the custom shortcut files were never


More information about the texworks mailing list