[texworks] Custom shortcuts are not working

Alain Delmotte esperanto at swing.be
Tue Jun 9 11:06:52 CEST 2009


Stefan Löffler a écrit :
> Hi,
> On 2009-06-07 21:52, Alain Delmotte wrote:
>> PS Now I'll try to understand the patch for Lua.
>> If I understand well, this would make the "actions.ini" unnecessary -
>> this never worked for me, Stefan?
> Actually, if all works as planned, it shouldn't be too difficult. As I
> posted on Google Code, you need to download the Lua dlls and development
> files and put them somewhere where C++ can find them. I gave a short
> description about how this may be done on Windows, but admittedly I
> didn't test it. And the rest should be taken care of for you by the
> patch utility ;).
> At least at the current state of development, it doesn't have much to do
> with the actions thing. The actions are there to redefine the shortcuts
> for certain commands in TW (such as those accessible from the menu or
> the toolbar) which are called "actions" in Qt. Lua scripting is intended
> for extending TW core functionality.
> In any case, the actions stuff should be working, though (it's working
> for me). A few notes/questions about that:
>  * Did you apply the patch to your current sources before build (it's
> not in the repository yet - took me some time to notice ;); see the
> patch utility)
Yes, done **
>  * Could you do the following:
>    Create a file C:\actions-test.ini containing the one line
>    actionOpen = Ctrl+1
>    Then edit your TeXworks.conf and put the following line
>    shortcutsMapFile=C:/actions-test.ini
>    right under the line
>    [General]
>    (and make sure there's no other line starting with shortcutsMapFile)
>    Then save the file, run TW, and press Ctrl 1, which should bring up
> the open dialog. If it doesn't we need to get into more debugging.
Doesn't work.
My actions.ini is now:
actionOpen = Ctrl+1
actionAbout_TW = Alt+,
actionBalance_Delimiters = F9
but none works and I tried with only the first line.


PS. ** I had to do the patch manually :-(  (for this one OK, but for Lua 
it will take more time!)
When I try using the program patch I get:
patching file PDFDocument.cpp
Assertion failed: hunk, file ../patch-2.5.9-src/patch.c, line 354

This application has requested the Runtime to terminate it in an unusual 
Please contact the apllication's support team for more information.

More information about the texworks mailing list