[texworks] fontconfig issues

Stephen Moye sgmoye at me.com
Fri Sep 26 15:57:48 CEST 2008

On Sep 26, 2008, at 9:33 AM, Jonathan Kew wrote:

> Sorry, compiling poppler on the Mac can be a bit of a pain (one  
> reason I'm building binaries is to save people bothering with this).  
> Doesn't Apple's X11 provide fontconfig, though? You might be able to  
> point configure to the right directories to use that.
> Alternatively, it's possible to build poppler without using  
> fontconfig, but this requires some patching; it's been mentioned on  
> the poppler mailing list earlier in the year.
> Some day we'll have a nice "how-to" document with all the tips and  
> tricks needed....
> JK
> On 26 Sep 2008, at 2:24 PM, Stephen Moye wrote:
>> I'm trying to compile texworks on Mac OS X, and I've hit a wall. In  
>> attempting to compile poppler, I get this:
>> ------------------
>> checking for FONTCONFIG... configure: error: Package requirements  
>> (fontconfig >= 2.0.0) were not met:
>> No package 'fontconfig' found
>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
>> installed software in a non-standard prefix.
>> Alternatively, you may set the environment variables  
>> and FONTCONFIG_LIBS to avoid the need to call pkg-config.
>> See the pkg-config man page for more details.
>> 9:13 ~/<1>poppler-0.8.7:
>> ------------------
>> The fontconfig package from fontconfig.org refuses to download, and  
>> i-Installer does not seem to have it currently available. What to  
>> do??
>> Thanks
>> Stephen Moye

Thanks -- I went back to fontconfig.org and the file (v2.6) downloaded  
in record time, compiled, as did poppler without so much as a hiccup.

Likewise, qmake seemed to work, but 'make' returns this:

	make: *** No targets specified and no makefile found.  Stop.

Almost there... what's next?

Thanks again.

Stephen Moye

More information about the texworks mailing list